
Zmanda Cloud Backup FAQ
The first sections of this document cover general questions regarding features, cloud, and support; the last 
section lists error messages and what to do about them. 

Terminology

What is Zmanda Cloud Backup?

What do the terms "backup," "restore," "upload," and "download" mean in the context of Zmanda Cloud 
Backup? 

What is a backup set?

What is amandabackup user?

What is Backup Folder (or why doesn't ZCB backup directly to cloud)?     

Features

What are the new features in ZCB 2.0.X?

What levels of backup are supported?

Can I do backup and upload at the same time? 

Can I do upload and download at the same time?

Can I copy the backup folder to another machine?

Configuration

What platforms/applications are supported?

Can I run ZCB as a user not belonging to Administrator group?

How do I enable VSS (Volume Shadow Services)?

How large should the backup folder be?     



Do I need to restore a full backup and then restore the incremental backup(s) to restore to a point in time?

How do I restore to a different directory?

How do I restore to different machine? 

Can I backup data from a mapped network drive? 

Can I use a mapped network drive as the backup folder (Local folder in Backup Where page)?

How do I backup NAS shares?

Can I backup Linux clients?

Does ZCB support FAT32 filesystem?

How do I configure ZCB to back up an SQL Server 2000 database?

How long are the backups retained in the local backup folder and on S3 storage? 

My backups take a long time to complete. What can I do to speed it up?

I cannot use the machine when backups are running. What can I do?

Does ZCB log events to Windows Event Viewer?

Why is the   Backup Size   on the Backup pane different from the   Upload size   on the Upload pane in the ZCB   
Monitor UI?

What are the three files in the   Total Backup Archives to Upload   on the Upload pane in the ZCB Monitor   
UI?

Amazon S3 Cloud 

How can I verify the validity of the S3 Certificate and Connection? 

How secure is my data with ZCB and Amazon S3? 

How to purchase Amazon S3 subscriptions?

How much are we spending? How much have we spent in the past?

How do I use a different Amazon S3 account? 

Who sends the monthly bill?

Support

I have a question not covered here. How do I get an answer?



How do I access the forums to see if my question has been answered previously?

Terminology

What is Zmanda Cloud Backup?

Zmanda Cloud Backup (ZCB) for Amazon S3 is part of the Zmanda Cloud Backup family of products; ZIB 
and Zmanda Cloud Backup (ZCB) are one and the same. 

What do the terms "backup," "restore," "upload," and "download" mean in the 
context of Zmanda Cloud Backup?

When a backup is performed, ZCB creates a local backup archive, which consists of the data being backed up 
(compressed in a .ZIP file), the backup index, and metadata associated with the backup. The local backup 
archive is then uploaded to S3 storage.

ZCB allows you to schedule the local backup and remote upload as a single operation or as separate 
operations, depending on the backup type you select. For example, Backup to S3 backup type copies the 
data to the local directory specified on the Backup Where tab and then immediately uploads the data to S3. 
Alternatively, Backup to Disk and Upload to S3 backup types perform these same actions separately, which 
allows you to schedule the upload when Internet traffic is light. 

What is a backup set?

All activities in ZCB are applied to backup sets. A backup set defines the parameters (the what, where, and 
when) for backing up a group of directories or an application such as Exchange. Each backup set can only be 
of a single type. For example, you cannot back up an Exchange server and and Windows System state in the 
same backup set. 

Backup sets are listed along the left edge of the ZCB display. You can create, edit, activate, and deactivate 
backup sets by right-clicking on them and choosing from the pop-up menu. Backup set names are limited to 
32 alphanumeric characters. A backup set must be activated (which is the default state) for the backups it  
defines to actually be performed as scheduled.

What is amandabackup user?

All ZCB services run as amandabackup user. The amandabackup user is added to “Backup Operators”, 
“Administrators” and “Users” groups. This user is essential for ZCB functionality. 

If ZCB machine is part of the domain and amandabackup user already exists in the domain, ZCB verifies the 
password of the amandabackup user. If the user does not exist in the domain and machine is the domain 
controller, the amandabackup user is created in the domain.

If the machine is not in a domain or the user does not exist in the domain and the machine is not a domain 
controller, a local user amandabackup is created with password that is provided.

The amandabackup local user may be deleted at the time of installation depending on whether or not you 



choose to preserve data during uninstallation.

What is Backup Folder (or why doesn't ZCB backup directly to cloud)?

ZCB provides disk based backup as well as cloud backup. The backup folder is a backup to disk location and 
can be used for restoration. To increase the performance as well improve reliability, ZCB writes backup 
images to Backup Folder before uploading the images to Amazon S3 cloud. 

Backing up directly to cloud would be unreliable because the data transfer over internet is unreliable. Backup 
folder minimizes the impact of communication failure/interruptions. 

Features

What are the new features in ZCB 2.0.X?

• 2.0.1 adds support for Windows 7 and Windows 2008 server R2.

2.0 features

• SharePoint (MOSS 2007, WSS 3.0) and MySQL 5.x applications are supported.

• Support for SQL server 2008 and System state for Windows Server 2008.

• Backup and restoration of network mapped drives.

• Zmanda Cloud Backup is supported on Amazon EC2 running Windows Server 2003.

• Cloud features 

• Secure transfer to cloud can be turned off to increase upload or download performance. This is 
recommended only when data is encrypted.

• Backup images can be stored in Amazon US or Europe data centers.

• Backup images transferred to cloud are checked for data integrity using MD5 checksums.

• Block size of the transfers to and from cloud. This can help in cases where are lots of network 
failures.

• Selective restoration of files. The user interface allows users select files that have to be restored. 
Please note that complete image will be transferred back to data center from the cloud.

• All events (backup, restore, upload and download) are logged in Windows events logs. Email address 
can be configured for each backup set. Email notification can also sent to Administrators. 

• Files can be excluded from filesystem backup. Wild card characters are supported in exclude 
specification.

• Data encryption using a PFX Digital Certificate provided by a trusted Certificate Authority. Secure 
Encryption/Decryption process, using Industry standard RSA algorithms. Please note that this 



encryption certificate is different from Amazon S3 certificate.

• Backup set full backup size estimation functionality allows users to estimate the size of backup 
window.

• Automatic validation of backup sets before saving configuration. This step helps in reducing backup 
failures due to configuration errors.

• Improved installation process using InstallShield.

What levels of backup are supported?

ZCB supports both full and incremental backups. Incremental backup (backup level 1) contains changes 
since the last full backup (backup level 0). Choosing incremental backup reduces the amount of data to be 
backed up and uploaded to Amazon S3. Current version of ZCB does not support incremental backups of 
MSSQL databases.

Can I copy the backup folder to another machine?

Not directly. To move a backup folder to a different machine, first upload from the source machine to S3, 
then restore the backup catalog to the target machine as described in How do I restore to different machine?.

Can I do backup and upload at the same time?

Yes. You can watch their progress in monitor page. 

Can I do upload and download at the same time?

Yes. 

Configuration

What platforms/applications are supported?

Platforms: Windows 2003 server, 2008 server, Windows 7 Windows XP and Windows Vista. 

Applications: can be NTFS file system, System state (active directory, registry, certificate server), MySQL 
5.x, SQL server 2000, 2005 and 2008, Microsoft Exchange 2003 and 2007, and Oracle 11g running on any of 
the listed platforms. 

Can I run ZCB as a user not belonging to Administrator group?

No. A Windows user belonging to Administrator's group can install and perform ZCB operations using the 
UI. 



On Windows XP and Windows 2003 server, if an user that does not belong to Administrator's group launches 
ZCB UI, the error message Write permission denied is displayed. User can right click on ZCB UI short cut 
and select Run As option. Specify the Administrator user password to launch ZCB UI.

On Windows Vista, Windows 7 and Windows 2008 server, if an user that does not belong to Administrator's 
group launches the UI using ZCB short-cut, the User Access Control dialog will appear. Enter Administrator 
user account name and password. ZCB UI will be launched.

How do I enable VSS (Volume Shadow Services)?

The Volume Shadow Copy Service must be enabled for ZCB backups. Although the Volume Shadow Service 
is enabled by default, it may have been turned off after Windows installation. To ensure that it is running: 

1. Right-click the My Computer icon and choose Manage from the popup menu. 

2. Expand the Services and Applications tree and locate the Volume Shadow Copy Service. 

3. If it is not started, do so. 

4. If necessary, change the General Properties to make the Startup Type Automatic rather than Manual. 

How large should the backup folder be?

The size you should allocate for the backup folder depends on number of backup sets, backup levels, backup 
and upload schedule. You should allow sufficient space to hold the number of backups specified by the 
retention policy. In general, the size depends on

1. Size of backup images in the backup set (incremental or full)
2. Backup scheduling used for the backup set (Backup, Backup+Upload)
3. Upload success or failures which depends on Amazon data centers and communication 

reliability

Do I need to restore a full backup and then restore the incremental backup(s) 
to restore to a point in time?

No. Zmanda Cloud Backup lets you select any point in time (based on when the last backup was performed, 
and then automatically determines which backups must be restored. 

How do I restore to a different directory?

The Restore Where tab includes an option to restore to a different directory. 

How do I restore to different machine?

The backup must reside in S3 storage; backups stored in the local backup folder cannot be restored to another 
machine. 



1. Install and run Zmanda Cloud Backup on the restore target machine. 
2. If the backup is encrypted, make sure the required encryption certificates and key container from the 

backup machine(s) are available on the restore target machine.
3. From the Tools menu, choose Restore Catalog to restore the backup. You must supply a host (host 

name of the original server) and backup set name to identify the backup used for the restore. If backup 
set name is not specified, all backup sets found in the original server, will be recovered on the new 
server. 

4. You can also restore the catalog to a temporary directory instead of the ZCB directory for testing.
5. All the recovered backup sets will be named “<backup set name> (<original hostname>)”
6. Use ZCB to restore the files as if they were on the original machine. You can also look at the 

reporting information for the recovered backup sets.

Can I backup data from a mapped network drive?

Yes. ZCB supports backing up mapped drives provided the shares have been mapped as user 
amandabackup. ZCB supports both Windows and SMB shares mapped as drives. Backup of NTFS 
encrypted files on mapped network drive will fail with Access Denied error.

Requirements:

1. On the machine where the share exists, make sure that amandabackup user exists and has the same 
password as the amandabackup user on ZCB client. 

2. The amandabackup user needs to have read-write permissions on the shared folder, which will be 
mapped. 

Perform the following steps on the ZCB client to map the shared folder to be backed up:

1. Login as user amandabackup.

2. Map a network drive for the Share to a drive letter say Z:\. Make sure that Reconnect at logon option 
is selected.

3. Login to the ZCB client machine using the credentials that will be used for performing backups say 
Administrator. Map a network drive for the Share with the same drive letter as before i.e. Z:\. Make 
sure that Reconnect at logon option is selected.

4. You should be ready to backup the mapped drive.

Please note that you will see the drive in the ZCB UI Backup What page only if you have started the UI as 
Administrator (not when the UI run with amandabackup user)

Can I use a mapped network drive as the backup folder (Local folder in Backup 
Where page)?

Yes. You can use a mapped network drive to store backup images. To configure mapped network drive as the 
backup folder, perform the following steps:

1. Ensure that amandabackup user has read and write access to the network share.



2. Map the network share as a mapped drive using the backup user (Administrator user).

3. In ZCB UI Backup Where page, use the browse button for the Local Folder to select the mapped 
drive.

How do I backup NAS shares?

1. Login to the ZCB machine as amandabackup user.

2. Map a Network drive of the NAS share. While creating the share, make sure that you select the option 
"Reconnect at logon". Note the Drive letter assigned for the Mapped drive.

3. Logout and Login to the machine as Administrator or the Windows user who performs ZCB backups.

4. Map the network share as a drive with the same drive letter (as in Step 2).

5. You should be able to select the drive from the Backup What page in ZCB user interface. Add the 
drive or folders in the drive to the backup set.

Can I backup Linux clients?

Yes using Samba. ZCB can backup data from mapped Samba shares from the Linux machine. There is no 
Linux ZCB client. Amanda Enterprise edition provides this functionality. Please contact Zmanda Sales 
(Email zsales@zmanda.com) for more information.

Does ZCB support FAT32 filesystem?

ZCB can backup only NTFS filesystem. FAT32 filesystem can be used for Backup Folder if backup 
encryption is not required. 

How do I configure ZCB to back up an SQL Server 2000 database?

1. Install and run Zmanda Cloud Backup on the server you intend to back up. 
2. Choose Backup from the Tasks menu in the upper right, then the What tab. 
3. Choose SQL Server as the Backup Type. 

Zmanda Cloud Backup will discover all the SQL Server 2000 instances and automatically adds them to the 
backup set. Automated server discovery works the same way for the other application types supported such 
as MS Exchange and Oracle. 

How long are the backups retained in the local backup folder and on S3 
storage?

Local and S3 backups are retained as specified by the retention policies entered in the Backup Where tab. 
You can choose to retain backups for months, days, or even years based on space availability and recovery 
requirements. Make sure that you have sufficient space (both locally and on S3) to meet the requirements of 
your backup retention policy. 

mailto:zsales@zmanda.com
http://www.zmanda.com/amanda-enterprise-edition.html


My backups take a long time to complete. What can I do to speed it up?

The upload speed depends on bandwidth availability. If necessary, adjust the schedule so that uploads occur 
when maximum bandwidth is available. 

I cannot use the machine when backups are running. What can I do?

ZCB uses the Windows Volume Shadow Services (VSS) to perform backups. VSS minimizes impact on the 
application. But because system resources such as CPU cycles and memory are shared, the impact can not be 
entirely eliminated. Compression in particular can consume significant system resources. 

This is why ZCB allows you to schedule backups separately from S3 uploads. 

Does ZCB log events to Windows Event Viewer?

Yes. All Backup, Upload, Download and Restore successful and failure events are logged. Following output 
shows an example of Backup failure. Windows log events can be used to trigger email and other notifications 
using various log monitoring tools available for Windows platform.

Event Type:     Error
Event Source:   ZCB
Event Category: Backup-Restore 
Event ID:       501
Date:           7/7/2009
Time:           5:40:33 PM
User:           N/A
Computer:       EXCH-SERVER-1
Description:
 BackupSet3 - Backup failed with errors.
 Error Details : File system not supported.

 Please check log files for details.

Why is the Backup Size on the Backup pane different from the Total Upload 
Size on the Upload pane in the ZCB Monitor UI?

The Backup Size on the Backup pane shows the size of Backup archive. The Total Upload Size on the 
Upload pane includes the backup meta data and catalog for the archive in addition to the backup archive. So 
the Total Upload Size will be greater or equal to the Backup Size value. The backup archive meta data and 
catalog is required to recover the catalog in case of disaster recovery of ZCB machine.

What are the three files in the Total Backup Archives to Upload on the Upload 
pane in the ZCB Monitor UI?

The three files that are uploaded are always Backup meta data, Backup catalog for the archive and Backup 
archive. The size of Backup meta data and catalog are usually significantly smaller to the size of backup 
archive. During upload, Upload so far (current file) value shows the amount of data uploaded for the file 
being uploaded.



Amazon S3 Cloud

How can I verify the validity of the S3 Certificate and Connection?

Choose Tools->Check Amazon S3 Connection. This causes ZCB to connect to S3 and validate the required 
S3 subscription and keys. You can use this test to validate your installation, or to troubleshoot failed 
uploads/downloads.

I'm getting Amazon subscription failure errors trying to access the Zmanda 
Network Downloads page. Why?

To access Zmanda Network downloads page, please use the following URL 
http://network.zmanda.com/index.php?redirect=download.php

Do not access using http://www.amazon.com/dp-applications     or   https://aws-  
portal.amazon.com/gp/aws/user/activation/index.html or http://network.zmanda.com/questionnaire.php to 
access ZCB product. Please note that this process ends up regenerating your Amazon S3 certificate which 
renders your old/current S3 certificate useless and ZCB will fail to upload data to S3 and restore data from 
S3. You will have to download new S3 certificate and import it in ZCB using ZCB user interface.

How secure is my data with ZCB and Amazon S3?

There are several levels of security provided by ZCB and Amazon S3 that ensure privacy and security of 
your data: 

• ZCB provides an option to encrypt your backup data by using Digital Certificates from Trusted 
Certificate Authorities. 

• In addition to encrypting the backup data, ZCB provides an option to transfer your data from your 
computer to Amazon S3 via secure 128-bit SSL. 

• Amazon S3 provides access controls that only permit authenticated access by ZCB with your own 
unique security certificate. You, and only you, maintain full control over who has access to your 
backup data. See this white paper from Amazon (requires Adobe Acrobat reader) for details. 

How to purchase Amazon S3 subscriptions?

Please click on Tools-> Purchase Subscription to buy Amazon S3 subscriptions for Zmanda Cloud Backup. 
The purchase process requires Zmanda Network login information. Please join Zmanda Network for free at 
http://network.zmanda.com/ 

After your purchase, Amazon S3 certificate will be available for download from Zmanda Network. Please 
download the certificate to the ZCB Windows server and import the certificate into ZCB configuration.

How much are we spending? How much have we spent in the past?

Please click on Tools-> S3 Billing to get browse monthly billing activity and see what is being spent so far 
this month. You will need your Amazon account information to access the bill. 

http://network.zmanda.com/
http://s3.amazonaws.com/aws_blog/AWS_Security_Whitepaper_2008_09.pdf
http://network.zmanda.com/questionnaire.php
https://aws-portal.amazon.com/gp/aws/user/activation/index.html
https://aws-portal.amazon.com/gp/aws/user/activation/index.html
http://www.amazon.com/dp-applications
http://www.amazon.com/dp-applications
http://network.zmanda.com/index.php?redirect=download.php


How do I use a different Amazon S3 account?

An additional S3 account requires an additional subscription, available from the Zmanda Network. 

Who sends the monthly bill?

Monthly bill for ZCB license, storage and transfer cost will be provided by Amazon. It will appear in 
financial statements (credit card statements) under heading AMZN PMTS(Services and Merchandise). 

Zmanda does not bill the customer directly. The bill will have specific entries for Zmanda Cloud Backup in  
addition to entries for other Amazon Web Services if you are using them. 

Support

I have a question not covered here. How do I get an answer?

Please click on Help->Contact Support. This will open your browser and direct it to the Zmanda Support 
Forums. Once logged in, you can ask your question in the Zmanda Cloud Backup support forum. If there is 
specific problem, you can open a support case using your Zmanda Network account.

How do I access the forums to see if my question has been answered 
previously?

Use your browser to access http://forums.zmanda.com and search the ZCB forums. 

Error Messages

backup failed
This error appears when the backup failed for any of a number of reasons, such as snapshot failure or 
running out of physical volume extents. Before contacting the Zmanda Support Team, choose Collect 
Logs from the ZCB Tools menu. ZCB then collects all the relevant files into an archive, displaying its 
name and location. Be patient; collecting the logs can take a few minutes. Attach the log file to your  
support request. Zmanda Support may ask you to set the log level to Debug (Tools->Log level->Debug) when helping you 
troubleshoot.

Backup root directory not found
This error indicates either of the following: 

• An invalid/non-existent Backup Folder has been specified in the backup set. 
• ZCB lacks the necessary permissions on the directory. 

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB. 

Backup Set directory not found
This error indicates either of the following: 

• An invalid/non-existent Backup Folder has been specified in the backup set. 

http://forums.zmanda.com/
http://www.zmanda.com/pricing.html


• ZCB lacks necessary permissions on the directory. 

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB. 

can not parse this index file
This error indicates either of the following: 

• An invalid/non-existent Backup Folder has been specified in the backup set. 
• ZCB lacks necessary permissions on the directory. (Backup Folder) 

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB. 

Can not open index file
This error indicates either of the following: 

• An invalid/non-existent Backup Folder has been specified in the backup set. 
• ZCB lacks necessary permissions on the directory. 

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB. 

Restore failed
There can be many reasons for a restore to fail. Before contacting the Zmanda Support Team, choose 
Collect Logs from the ZCB Tools menu. ZCB then collects all the relevant files into an archive, 
displaying its name and location. Be patient; collecting the logs can take a few minutes. Attach the log 
file to your support request.

A backup set with the same name already exists.
Duplicate backup set names are not allowed. Choose a different name. 

Restore Catalog command failed. Please look in the log file for more details.
The restore catalog command failed for any of a number a reasons, perhaps due to S3 connection 
problems or insufficient space on the local folder. Check the logs for further information. 

Unable to create backup set Backup_set_name
Check that the local disk has not run out of space. 

Backup Set with name Backup_set_name already exists.
Duplicate backup set names are not allowed. Choose a different name. 

Unable to create temp file
Make sure that ZCB has permission to write to ZCB_installation_directory\misc. 

Unable to save Backup Where parameters for backup set Backup_set_name
Make sure that ZCB has permission to write to 
ZCB_installation_directory\conf\Hostname+Backup_set_name. 

Failed to save Backup What parameters for backup set Backup_set_name
Make sure that ZCB has permission to write to 
ZCB_installation_directory\conf\Hostname+Backup_set_name . 



The format of the restore time not correct.
Restore time must be specified in HH:MM format. 

Collection of ZCB logs failed.
On Windows Vista, Windows 7 and 2008 Server, the Tools->Collect Logs can have errors if they are 
not run as Administrator user. To resolve this issue, right click on ZCB Support in Start->Programs 
menu and click on Run as Administrator.

Failed to Validate encryption certificate : <CertificateName>
The encryption certificate name entered in ZCB UI Backup What for the backup set is invalid. 
Encryption certificate name must have been imported into the amandabackup user profile on the ZCB 
machine.

Decryption initialization failed while finding certificate : <CertificateName>
The encryption certificate CertificateName used at the backup time must be available for restoration 
of encrypted backup images. It should be have been imported into the amandabackup user profile on 
the ZCB machine where restoration is being done.

Decryption initialization failed while importing session key.
You might encounter this error, if you are restoring on a machine different from where the archive, or if 
the amandabackup user profile on the same machine was deleted manually or as part of uninstallation. 
This is a result of not importing the encryption key container used during encryption. To resolve this, 
you will have to import the necessary key container from the machine where the archive was backup 
encrypted. See Getting Started (Help>Getting Started in the UI or Zmanda Network documentation) 
guide for information on how to import key containers.

Failed to initialize COM for VSS.
Failed to initialize VSS.
Failed to collect writers information.
Error Backup failed for more than 100 or 50% of the selected files. Check Volume Shadow Copy 
services.

Writers status is not stable. Try after restarting Volume Shadow Copy service. Please run 'vssadmin 
list writers' to identify the problem vss writer.

These error messages related to VSS (Volume Shadow Services) can be seen during backup or 
validation of backup set. The application event logs should be checked for errors. Based on error codes 
in the logs, corrective action should be performed. The Windows command “vssadmin list writers” can 
also be useful to identify VSS writer problems. Restarting Volume Shadow Copy service fixes most 
VSS writer problems. 

The list of files that were not backed up in the last backup run can be found in BackupErrors.txt file in 
the ZCB Debug folder. A similar debug file is available for restore failures (RestoreErrors.txt in the 
ZCB Debug folder)

Amazon S3 Certificate not found in the installation directory. Backups and Restores to the S3 cloud 
will not work. Please purchase S3 subscription or download S3 certificate from Zmanda network.

Backing up to Amazon S3 and restoring from S3 requires an authentication certificate. This certificate 
is available as part of product subscription. Please use Tools->Purchase Subscription to purchase a 
subscription. If you are already a product subscriber, download the certificate from Zmanda network 
account and import the certificate into ZCB using Tools->Import Cloud Certificate.

Time-mismatch: Difference between Amazon S3 time and System time is too large. Please check your 
server date and time.



Amazon cloud requires the system time of ZCB machine to be correct. Please synchronize the system 
time with valid time (NTP) server.

Invalid User token: The provided token is malformed or otherwise invalid.
Failed to connect to Amazon S3 due to invalid certificate
Invalid access key: The AWS Access Key Id you provided does not exist in our records.
Invalid Secret key: The request signature we calculated does not match the signature you provided. 
Check your key and signing method.

The Amazon S3 certificate installed on the machine is not valid. Please download S3 certificate from 
Zmanda Network and import the certificate to ZCB. Check Amazon S3 subscription using Tools->S3 
Billing.

Storage cloud communication errors
Communication with Cloud failed. Detailed error message is available in the log files. Use Tools-
>Check Amazon S3 Connection to verify connectivity to the cloud. If the connection is good, try 
resuming the upload operation will work. Failed uploads can be resumed from Reports page. Select the 
backup job report and right click to perform retry upload operation. The failed upload resumes from the 
failed block (not from the beginning of the backup image). 

mysqldump: Got error: 2003: Can't connect to MySQL server on <IP address/name> (10061) when 
trying to connect

Backup of MySQL database fails with this error message. Check to see if the MySQL server is running 
on the server with the IP address or name mentioned in the message. Backup of MySQL database 
requires MySQL server to be running.

Upload failed due to backup run failure
This message appears in Upload pane of Monitor page. Failed backups cannot be uploaded. Look at 
Backup pane in the Monitor page for backup errors.

ERROR: You have launched 'Collect Logs' using <user name> user. The tool will fail to collect logs 
correctly for any user other than Administrator. Please run 'Start Menu > Programs > Zmanda > 
Zmanda Cloud Backup > ZCB Support' using 'Run as Administrator' option

ZCB log collection for Zmanda support must be performed as Administrator user. 

Validation of backup set <backup set name> failed. Check if ZCB service ports (see Tools > Advanced 
Options) are used by another software using netstat command
ZWC service could not be started. Please check if ZCB ports (Tools > Advanced Options) are in use

ZCB uses two TCP ports for its operations. Default port numbers are 10080 and 10081. If these ports 
are used by some other software installed on the ZCB machine, the above error message is displayed. 
Users can change ZCB ports from the UI using Tools > Advanced Options. Use netstat command from 
the Windows command shell to determine the list of ports used by software applications running on the 
machine.

Could not open file
ZCB does not have the necessary read/write permission on the Backup Folder. Ensure that ZCB has 
write permissions on the Backup Folder. 

Nothing to do
This message indicates you are trying to restore an unsuccessful backup. 

Backup root directory not specified, Assigning default value
This error indicates either of the following: 



• An invalid/non-existent Backup Folder has been specified in the backup set. 
• ZCB lacks necessary permissions on the directory. 

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
page. Make sure that Backup Folders are present and accessible to ZCB. 

Backup info fields not specified
This error indicates either of the following: 

• An invalid/non-existent Backup Folder has been specified in the backup set. 
• ZCB lacks necessary permissions on the directory. 

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
page. Make sure that Backup Folders are present and accessible to ZCB. 

Restoring from a backup which was not successful
This message indicates you are trying to restore an unsuccessful backup. 

Backup status is not available in the index file
This message indicates you are trying to restore an unsuccessful backup. 

Restoring from this may not be successful
This message indicates you are trying to restore an unsuccessful backup. 

Unable to access following File(s)/Folder(s) that are part of the <backup set name> backup 
configuration:
<list of file(s)>
Please save backup set.

This warning message appears if some files that were part of backup set are no longer in the system. 
The message identifies the list of files that are missing. Users are expect to save the backup set so that 
the missing files are removed from the backup set.

Please perform a Full Backup before an Incremental backup
At least one full backup must be performed for a backup set before incremental backup can be 
performed. Incremental backup contains all changes since the full backup of the backup set.

Validation of backup set not done. Another operation already in progress
Validation of a backup set cannot be performed when backup or restore operation in the backup set is in 
progress. The backup set configuration is saved. The backup set should be validated later using 
File>Validate Backup Set.
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