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Introduction to Zmanda Cloud Backup 
Zmanda Cloud Backup is the complete backup solution for Windows servers. It backs up file systems and 
live applications such as Microsoft Exchange and SQL Server to highly dependable storage cloud – 
Amazon S3. 

User Manual 
Overview 
Zmanda Cloud Backup is a secure and convenient way to back up Windows workstations and servers to 
Local Folder or Cloud storage (Amazon S3). With Zmanda Cloud Backup, you can select any of the 
following as backup type:  

• Windows NTFS files and folders  
• Microsoft SQL Server 2000, 2005 and 2008 
• Microsoft Exchange Server 2003, 2007 and 2010  
• Microsoft Share Point Server 2007, 2010 and WSS 3.0 
• Windows System State (registry, certificate server and active directory information) 
• MySQL Server 5.0 and 5.1  

 
SQL Server, Exchange Server and SharePoint server configurations are automatically discovered by ZCB. 
No additional configuration is necessary. Zmanda Cloud Backup has options to use native Windows 
compression and supports digital certificate based encryption for the backup data.  

System Requirements 
To be able to use ZCB, please check that your system meets these requirements:  

• Windows XP (Home or Pro) with SP2 or higher. 
• Windows 2003 with SP2 or higher. 
• Windows Vista, Windows 7, Windows 2008. 
• Java Runtime Environment (JRE) 6 Update 20 or higher. 
• The Volume Shadow Copy Service must be enabled. Although the Volume Shadow Service is 

enabled by default, it may have been turned off after Windows installation. To ensure that it is 
running:  
o Right-click the My Computer icon and choose Manage from the pop up menu.  
o Expand the Services and Applications tree and locate the Volume Shadow Copy Service. If it 

is not started, change the General Properties to make the Startup Type Automatic rather 
than Manual.  

• The Remote Registry Service must be enabled before installation. 
• Zmanda Cloud Backup must be installed and all ZCB operations must be performed as an user 

that has Administrator privileges. 

http://aws.amazon.com/s3/
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• Zmanda Cloud Backup stores the metadata about the backup archives in the Installation folder 
and not in Local Backup Folder. This metadata is very important for restoration of backup 
images and hence please ensure sufficient disk space is available in this Installation folder for 
storing this metadata files. The amount of space required depends on number of backup sets, 
backup images and number of files/objects in each backup image. 

• Zmanda Cloud Backup requires access the following TCP ports: Port 10080 & 10081, which are 
default ports used by ZCB for backup and restore. If the default ports are in use, you can specify 
alternate ports to be used by ZCB. Please refer to the Changing TCP Ports for use by ZCB section 
in this document.  

Installation 
The Installation of ZCB involves two steps – installation of software and importing ZCB certificate to 
Zmanda Cloud Backup software. Both 32bit Windows and 64bit Windows ZCB software and ZCB 
certificate are available under the Zmanda Network Downloads tab. 

 In case you do not find the ZCB software or the ZCB certificate and you have a valid subscription to Zmanda Cloud Backup, 
please contact Zmanda Support by sending an email to support@zmanda.com or opening a support case using Support tab 
in Zmanda Network. 

Installation 
The Zmanda Cloud Backup product uses InstallShield installer. Run setup.exe from the zip archive file to 
run the installer. The installer will check for system requirements such as Java JRE before installation. 

Importing the ZCB certificate  
After installation of software is completed, download the ZCB certificate from Zmanda Network to the 
ZCB machine. The ZCB certificate would be named s3.zmanda and must be imported into ZCB User 
interface using Cloud > Import Cloud Certificate menu option. 

Unattended installation 
If you are planning to install ZCB on multiple machines, you should record the user input for playback. 
Using the user input recorded file, you can install ZCB using command line on multiple machines in an 
unattended manner.  

To record user input, run  

setup.exe /r /f1<recording file>  

The recording file will contain all user input for playback. 

ZCB installer can read the user input recorded file from the same directory. Alternate location for user 
input can be provided using /f1 option. The installation log file will be created in same directory (default: 
Setup.log). Alternate location for the log can be provided using /f2 option. An example command for 
replaying user input from C:\Temp\Setup.iss file. 

 
setup.exe /s /f1"C:\Temp\Setup.iss" 

mailto:support@zmanda.com
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The command will complete before the installation or uninstallation process is completed. Use /WAIT 
flag if you want the setup.exe command to wait for the process to be completed. For example: Run the 
following installation command that will wait till process is completed in Windows command shell 

start /WAIT setup.exe /w /s /f1"C:\tmp\Setup.iss'' 

The Zmanda Network provides default install.iss and uninstall.iss that can be used of unattended 
installation and uninstallation. This setup files assumes 

1. ZCB will be installed in C:\Program Files\Zmanda\Zmanda Cloud Backup folder. You will be 
asked to provide a password for the amandabackup user. Please note this password as it may 
be required for advanced configurations 

2. ZCB uninstallation will not preserve configuration data 

ZCB certificate has to be downloaded and imported into each ZCB instance you have running. You can 
use different ZCB certificate if you want to use different Amazon billing accounts. 

Configuration 

Backup Sets 
All activities in ZCB are applied to backup sets. A backup set defines the parameters (the what, how, 
where, and when) for backing up a group of directories or an application such as Exchange. Each backup 
set can only be of a single type. For example, you cannot back up an Exchange server and Windows 
System state in the same backup set. 

Backup set names are limited to 32 characters. You cannot use Windows reserved characters such as 
/\|?_.<>*":+&- 

Backup Levels 
ZCB supports full, differential and incremental backups.  

Full backup: This level of backup makes ZCB to back up all the data associated with the backup set. This 
is also called as backup level 0. 

Differential backup: This level of backup makes ZCB to back up only the data which changed since the 
last successful full backup. This is also called as backup level 1. 

Incremental backup: This level of backup makes ZCB to back up only the data which changed since the 
last successful full or last incremental backup. This is also called as backup level 2 or more. 

Choosing differential and incremental backup reduces the amount of data to be backed up and 
uploaded to Amazon S3. Incremental backups can be smaller in size compared to differential backups. 
But, differential backups allow for faster restoration compared to incremental backups. 
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It is not possible to do mix incremental and differential backup for a backup set. If you configure a 
backup set to do differential backups, you cannot use incremental backups for the backup set. 

 Please note that restoration from an incremental or differential backup needs the backup data from the corresponding full 
backup. Hence, as a best policy, please ensure that retention policies and backup locations for the full and 
incremental/differential backups meet this condition. For e.g. keeping full backup on local disk while keeping 
incremental/differential on cloud will make incremental/differential backups useless if you happen to lose the disk 
containing the full backup data. 

Working with Backup Sets 
Backup sets are listed along the left edge of the ZCB display. While on the Backup page, you can create, 
edit, activate, deactivate and validate backup sets by right-clicking a set and choosing from the pop-up 
menu. The same operations are also available in the File menu in the user interface.  

Activating/Deactivating a backup set: Deactivating a backup set would mean that no operations 
such as backup or restore can be performed on that backup set. ZCB will begin skipping all scheduled 
backups for this backup set. Activating the backup set will make ZCB begin honoring the scheduled 
backups again. By default a backup set is in activated state. 

Validating a backup set: This is a simple way to check whether the essential configuration for the 
backup set is correct or not. If there are errors during validate, it indicates that the ZCB won’t be able to 
use the configuration provided by the user to perform backup/restore operations correctly. Backup set 
configurations are automatically validated when configurations are saved as well as before any backup 
run is performed. 

Configuring Backup Sets 
ZCB makes it easy to configure backup sets by grouping the configuration options in four logical groups - 
Backup What, Backup How, Backup Where and Backup When.    

Backup What 
The Backup What section lets you select a Backup Type (such as Windows File System, Windows 
system state, and a number of common applications such as Exchange). 

Backup Where 
ZCB provides the flexibility of backing up to cloud, to a local disk or a combination of both.  It also allows 
retention periods to be configured separately for cloud and disk storages. This means that you have the 
flexibility to implement a disaster recovery strategy of your choice.  

You can use ZCB to perform following types of backups: 

Backup to Cloud 
This new operation is available from ZCB 4.0 onwards. This operation makes ZCB to perform backups 
and transfer the backup data directly to cloud. The backup data is not stored on the local disk. Generally, 
this operation is used when ZCB is being used as only the offsite backup solution.  
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Backup to Disk 
This operation directs ZCB to perform backups and store them only on the local disk. The backup data is 
not uploaded to cloud. Generally, this operation is used as the first step in the two step approach to 
cloud backup. The backup is first stored on disk and a separate upload operation is scheduled later to 
upload the backup data to cloud at an appropriate time given the bandwidth and availability of other 
resources. 

Please make sure that the local folder you select has enough available space. While calculating this 
space, please keep in mind the retention policy configured in the Local Storage section in the Backup 
Where section. Please refer to the Retention policies section for more details. 

Backup to both disk and cloud 
Prior to ZCB 4.0, this operation was called “backup to S3”. This operation directs ZCB to first perform 
backup to disk and upon its completion start uploading it to the cloud. Hence, the backup data is stored 
on the local disk as well as on the cloud. For how long the data will exist on local disk and cloud is 
governed by the retention policies configured. Please refer to the Retention policies section for more 
details. 

Generally, this operation is used when a local copy of backup data is required for faster restores and 
extra redundancy. Cloud storage is used as the secure offsite data protection solution. 

Please make sure that the local folder you select has enough available space. 

Cloud Storage Options 
Amazon data center locations are US Standard, US-West (Northern California), EU (Ireland), Asia Pacific 
(Singapore) and Asia Pacific (Tokyo). Please note that the transfer and storage cost for some locations 
may be different. You can check out the pricing for each location on ZCB website here.  

It is possible to have different cloud storage location for different backup sets. However, please note 
that once configured, you can’t change the cloud storage location for a backup set. This is because if 
backup data is spread across multiple cloud locations, it will be difficult for ZCB to perform restores. 

Local Disk Storage Options 
ZCB supports backing up to a local disk, an external hard disk and a network mapped drive.  

Retention policies 
A retention period tells ZCB about how long to retain backups, both locally and on local disk storage. 
Please make sure that the selected local folder has enough available space which depends on retention 
period configured and size of backup data. 

The retention policy on the Amazon S3 is implemented as Purge_ZIB_Backups task scheduled on the 
Windows machine. This task is performed at midnight every day. This task should not be removed from 
the Windows task scheduler. If the machine is not running at the time, backup images on the local folder 
as well as the cloud are not removed if retention policy has expired. However, the next day’s scheduled 
task will try to delete this expired data again. 

http://www.zmanda.com/zcb-pricing.html
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Retention Override 
ZCB provides an option to intelligently retain the last copy of a Full backup either from disk or from the 
Cloud. Enabling this option ensures the availability of the last Full backup irrespective of the retention 
policy set for the backup set. ZCB will ensure that the last copy of a Full backup will not be deleted even 
if its retention period expires. 

Bandwidth Throttling 
By default, ZCB attempts to transfer data to and from the cloud at the maximum possible speed. Hence, 
ZCB always attempts to use the maximum bandwidth you have available. 

However, if you wish to specify the maximum bandwidth ZCB should use for upload and download of 
data, you can do so. ZCB allows you to specify these two values: 

Max Upload Rate: This value, in kilobits per second, refers to the maximum bandwidth ZCB will use for 
uploading backup data to the cloud. 

Max Download Rate: This value, in kilobits per second, refers to the maximum bandwidth ZCB will use 
for download backup data from the cloud. 

ZCB allows you to set these two values both at a global level and at a backup set level. For configuring 
these values globally, across all the backup sets, please go to Preferences > Bandwidth. For configuring 
these limits at a backup set level, so that they override the global values, please go to Cloud Storage 
sub-section on the Backup Where section. 

Secure Transfer (SSL) 
ZCB supports secure transfer of data to cloud using OpenSSL version 0.9.8. To enable this, please enable 
the check box under the Cloud Storage sub-section on the Backup Where section. 

You can select secure transfer to cloud irrespective of whether data is being encrypted using digital 
certificate encryption.  

Please note that if the data being backed up is public such as public web sites, upload performance can 
be improved by not using secure transfer to cloud (internal testing has shown an improvement for 15-
20% and actual performance depends on lot of external factors).  

 

Backup How 
Users can control how backups will be handled by ZCB. ZCB supports compression and encryption of 
user data. It is worth noting that the backup data undergoes compression and encryption as it is getting 
backed up. It is written to disk or uploaded to cloud only after this process. This ensures that at no point, 
the backup data on disk is unencrypted.  

The user can specify the following settings: 
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Compression: This can help save the network bandwidth and backup storage space. Compression level 
can range from fast (quick compression but does not get maximum compression ratios) to Best 
(maximum compression ratio but uses more CPU resources).  

Encryption: ZCB uses industry-standard RSA RC4 algorithm for backup encryption. RC4 is RSA's standard 
streaming encryption algorithm. ZCB supports Windows PFX (Personal Information Exchange) 
certificates only. The backup archive stores all encryption metadata information in encoded form 
including the certificate that was used to encrypt. The SHA1(secure) hash of the certificate is also stored 
in the archive. 

ZCB performs encryption using Windows PFX (Personal Information Exchange) digital certificates 
installed for the amandabackup user. Please note that this certificate is different from Amazon S3 
certificate downloaded from Zmanda Network and it is not provided by Zmanda. 

ZCB offers 100% data privacy by allowing users to specify their own digital certificate to encrypt data. 
Since the encryption certificate is known only to the user, only the user can decrypt the data. This means 
that if the certificate is lost, encrypted data cannot be recovered. Hence, please store the encryption 
certificate used for encryption carefully. 

Before you can enable encryption, you need to import PFX certificate to the Windows Certificate Store. 
Please refer to the Setting up PFX certificates for Encryption section for information how to do this. 

To enable encryption using an installed certificate, select the certificate from the Encryption dropdown 
in the Backup How section on the Backup page. After specifying the encryption certificate, please click 
on Save Backup Set button which will trigger validation of the backup set. If there is any problem with 
encryption certificate, ZCB will show a warning message to you.  

Please note that ZCB 4.0 has a known issue for 64 bit platforms. On the 64 bit platforms, the automatic population of 
available certificates in the Encryption dropdown doesn’t work. As a workaround, on 64 bit platforms you need to use the 
Choose Encryption Certificate option in the Encryption dropdown and type in the certificate name manually.  

Please note the following about encryption with ZCB: 

• ZCB can decrypt the backup image only if the encryption certificate (in the same form during 
backup) is present on the target machine. A renamed certificate of the same form will also be 
able to decrypt the files.  

• User will be able to view the files (filenames) stored within the archive through Winzip and 
PKZIP Windows utilities, but will not be able to decrypt through these utilities. Only ZCB can 
decrypt the backup files. 

• It is important that the amandabackup user has the same password during backup and recovery 
process. Otherwise, the decryption during restoration will fail. 
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Backup When 

Pre-backup and Post-backup Actions 
ZCB offers the flexibility of running custom commands or scripts before it begins a backup or after it 
finishes a backup. For instance, if one wishes to copy certain files from outside the backup directory to 
inside just before backup is run, he/she can configure a pre-backup action. Similarly, if one wants to 
invoke another program (such as an old data purging script) after backup is completed by ZCB, a post 
backup action can be configured. 

To configure these actions please select the backup set from the left hand pane and go to Backup page. 
In the Backup When section, under the Backup Set Preferences tab, you can locate this setting. Please 
browse for a batch script or other executable program present on your machine which you want ZCB to 
execute before/after the backup and save the backup set configuration. 

To use this feature to meet your purpose, please note the following points: 

• If you want to add parameters to the above script or program, then please click on the Pre-
backup/Post-backup icon again and add the parameters to the command which is shown by 
ZCB.  

• If the configured Pre-backup or Post-backup actions fail upon being run by ZCB, backup is 
marked fail. The exit status of the failed command can be found in the ZCB log file. If you wish 
to make ZCB continue with the backup, despite any error in running the command, you can do 
so by making your script exit with a special exist status of 65531. 

• If your script is opening files for reading/writing, make sure that file names are fully qualified 
file names (e.g. C:\backup\Log.txt). Unqualified names such as “Log.txt” will result in files 
getting created inside C:\Windows\system32 folder. 

User Credentials 
If backing up your data requires the permission of some other windows user, you can make ZCB use the 
credentials of that user.  

To configure this, please select the backup set from the left hand pane and go to Backup page. In the 
Backup When section, under the Backup Set Preferences tab, you can locate this setting. Please provide 
the username and password of the windows user to be used by ZCB for backing up data. 

Email Notification 
You can configure email notifications to be sent when each operation completes. This can be done both 
at the global level (for all backup sets) or at a backup set level. Please refer to the Email Notification  
section for more details. 

Scheduling 
ZCB offers powerful and completely flexible scheduling options.  You can schedule each of the following 
operations independently– Backup to cloud, Backup to disk, Backup to both disk and cloud and Upload 
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backup data from disk at your desired time. This gives you the flexibility such as scheduling Backup to 
disk operations on weekdays and Upload backup data from disk operation on weekends.   

To add scheduled backup runs for a backup set, please select the backup set from the left hand pane 
and go to Backup page. In the Backup When section, under the Scheduled Backup tab, click on the Add 
schedule button which will show you schedule templates you can choose from. Each template is 
completely customizable. Don’t forget to add “Save <backup set>” button at the bottom of the Backup 
page to commit the schedule. 

Please note that a backup set can have full and incremental backup or full and differential backups. A 
policy with mixture of incremental and differential backups is not permitted. 

Please note that backup operations are scheduled as the Windows SYSTEM user and executed in 
SYSTEM user context. If the local folder specified in the Backup Where is a mapped drive, the SYSTEM 
user will not have privileges to write to the drive. You should modify the ZCB scheduler entry in the 
Windows Task scheduler to run as local amandabackup user or Domainname\amandabackup domain 
user as shown below. You will be required to provide the amandabackup user password. This 
modification can be done only by the Administrator. You may have to add domain amandabackup user 
to the group policy as an user with "Log on as batch job” rights. 

Detailed description of some configurations 

Setting up PFX certificates for Encryption 
A PFX file is a specially formatted file which includes the SSL Certificate, Private Key and optionally any 
required Intermediate CA Certificates. When you use a PFX certificate for encryption, it works just like a 
password for encrypting backup data. 

Getting a PFX certificate 
There are two kinds of PFX certificates – signed certificates and self-signed ones. Signed certificates are 
issues by third party CAs such as Verisign. You can find an explanation of the differences between signed 
and self-signed certificates here.  

Unless your backup data is to be sent to some external party (which may want to verify the authenticity 
of data), self-signed certificates can be safely used for encryption with ZCB. You can generate your own 
self-signed certificate for free by downloading simple-to-use tools such as abylon selfcert. Openssl utility 
also can be used for this purpose. 

If you already have a personal certificate but it is not in PFX format 
If you have an installed non-PFX certificate, you can export it to a PFX file. Please note that you need to 
have access to its private key. 

To do this, from the Windows Start menu, click Run and enter certmgr.msc. Now, find the certificate to 
export, double-click it, click Details. Choose the Copy To File option, which will let you select a location 
for the exported certificate. When exporting the certificate, make sure that: 

http://webdesign.about.com/od/ssl/a/signed_v_selfsi.htm
http://www.abylonsoft.com/selfcert/
http://gnuwin32.sourceforge.net/packages/openssl.htm
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• The Yes, export the private key option is checked (This option will appear only if the private key 
is marked as exportable and you have access to the private key.) 

• the Delete Private Key if export is successful option is left unchecked 

After the file has been saved, close the certmgr.msc utility. The exported certificate should be in a folder 
that is accessible by the amandabackup user.  

Importing the PFX certificate  
To use encryption with ZCB, you need to import your PFX certificate into Windows certificate store using 
the procedure described in Importing the PFX certificate into certificate store for a user section below. 
You need to complete this procedure for the following Windows users: 

• amandabackup 
• Administrator 
• The Windows user who has launched the  ZCB user interface (if manual backups are going to be 

performed), say “johndoe”. 

Importing the PFX certificate into certificate store for a Windows user 
1. Log on to the ZCB machine as the desired Windows user. 
2. Double click on the PFX certificate file to start the Certificate Import Wizard.  The password 

used to protect the private key must be entered. For encryption with ZCB: 
a. Do NOT select the option - Enable Strong private key protection. You will be prompted 

every time the private key is used by an application if you enable this option. 
b. Select the Mark this key as exportable option. 

3. Choose all the default options and complete the import. 

 

Performing Backups 
Once you have saved the backup set, you can perform backups. You can either launch a manual backup 
or add schedules to backup automatically at a specific time.  

To run a manual backup, select the backup set from the left hand pane and go to Backup page. In the 
Backup When section, under the Backup Now tab, choose the operation which you want to run and 
click on the button just below it to launch the selected operation. To configure scheduled backup runs, 
please see the Scheduling section below. 

Below is the detailed information for all applications you can backup using ZCB.  

Windows File System 
Overview: ZCB can perform full (all files), differential (only files which changed since last full backup) 
and incremental backup (only files which changed since any last successful backup) of windows NTFS file 
system.  It can backup open files and doesn’t have any limit on the size of the files to be backed up. In 
addition, it can also backup files from an external portable hard drive or a network mapped drive. 
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Functionality: When backing up a NTFS file system, ZCB lets you select directories and files from a 
browser tree. You can specify the list of files to be excluded in case of Windows file system backup. 
Windows file systems support wild cards in the exclude specification. Wild cards "*" (match one or more 
character) and "?" (match exactly one character) are supported.  The pathname in exclude specification 
must be absolute path. For example: User is backing up C:\Data directory. User wishes to exclude files 
under a sub-folder exclude and files with *.jpg extension. The exclude specification should be 
"C:\Data\exclude"  "*.jpg. 

The list of patterns in the exclude specification for Windows file systems should be separated by space 
character. 

Requirements: 

• Only Windows NTFS file system is supported. 
• For backing up open files, the Volume Shadow Copy Service must be enabled. 
• If your backup set includes files from encrypted volumes, or files that individually have 

encryption enabled, you might want to back up the associated encryption keys too so that you 
can access the files after restoring them with ZCB. 

 
A note about Network Mapped Drives: 

You can use ZCB to back up the data on network drive and also choose it as your local storage for 
keeping your local backup archives. Please note the following requirements to make sure that ZCB has 
the adequate privileges for your desired use case: 

• Make sure that amandabackup system/domain user has the permission read/write on the 
network drive. 

• Only if you wish to run Backup to Cloud operation, please note the following additional 
requirements 

o Scheduled backups: Before adding the schedules, please provide the user credentials of 
amandabackup user in the Perform backup with specified credentials section under the 
Backup Set Preferences tab.  

o Manual backups: The ZCB user interface must be launched “as administrator” and 
“administrator” user needs to have permission to read/write on the network drive. 
 

Microsoft SQL server  
Overview: ZCB performs VSS based backup of databases and their log files. From ZCB 4.0 onwards, one 
can perform backup of a specific database on a specific SQL server instance also. Full and Differential 
backups are supported. Log only backups are not supported. Only Full backups are supported for MS 
SQL 2000 server. 
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To configure MS SQL server backups, create a new backup set and choose SQL Server from the 
dropdown list in the Backup What section. ZCB will discover all SQL Server components and will display 
them in the Backup What section in the following format: 

MSSQL-2008\Servername\InstanceName\DatabaseName 
MSSQL-2005\Servername\InstanceName\DatabaseName 
MSSQL-2000\Servername\InstanceName\DatabaseName 
 
 

From this list, you can select the ones which you wish to back up and save the backup set. 

Functionality:  ZCB supports Simple Recovery Model, Full Recovery Model and Bulk Recovery Model for 
SQL server databases. If the database is in Simple Recovery Model, the full backup will contain .MDF, 
.LDF and .NDF (in case of filegroups) files in the backup image. The differential backup will contain .LDF 
files. If the database is in Full Recovery Model, the full backup will contain .MDF, .LDF and .NDF (in case 
of filegroups) files in the backup image. The differential backup will contain .MDF-Offset (partial file of 
.MDF database that has changed), .LDF and .TRN (transaction logs flushed to the disk) in the backup 
image. If the database is in Bulk-log Recovery Model, the full backup will contain .MDF, .LDF and .NDF (in 
case of filegroups) files in the backup image. The differential backup will contain .MDF-Offset (partial file 
of .MDF database), .LDF and .TRN (transaction logs flushed to the disk) files in the backup image. 

Please note the following: 

• The master database is only backed up as part of the full backups. During restore of master 
database, SQL server is stopped and is restarted after restoration. 

• Any read-only databases are only backed up as part of the full backups. 
• ZCB will only back up MS SQL databases that are in Mounted state.  
• ZCB only backs up the MS SQL databases. It does not back up other MS SQL files such as 

program installation files, etc. To protect an MS SQL server from a disaster, make sure that you 
create a separate backup set to back up the other crucial MS SQL files.  

• Please note that SQL server backup set validation checks for amandabackup SQL user but does 
not check if the privileges are sufficient for backup and recovery. 

Requirements: 

• The Volume Shadow Copy Service must be enabled. This means that its startup type must be 
either automatic or manual. Please refer to the Requirements section to know how to do this. 

• Microsoft recommends that MS SQL and System State backups should not be run 
simultaneously.  

• Please ensure that you have enabled TCP/IP on your MSSQL server. You can do this using the 
"SQL Server Configuration Manager” tool. 

• The SQL writer service must be running at the time of backup and recovery. Microsoft 
recommends that the SQL VSS Writer service be automatically started. MSDE writer is not 
sufficient for backup and recovery. 
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• The amandabackup user must be added as a SQL server user with sufficient privileges. To add 
the user in SQL server Management Studio, click on Security > Logins > Add New Login. Add the 
amandabackup user account and give it privileges. You can just add it to sysadmin server role.  

Microsoft Exchange Server 
Overview: ZCB supports full, incremental and differential backups of MS-Exchange. From ZCB 4.0 
onwards, one can perform backup of a specific database on the Exchange Server. 

To configure MS Exchange server backups, create a new backup set and choose Exchange from the 
dropdown list in the Backup What section. ZCB will discover all Exchange Server components i.e. 
Mailbox  and will display them in the Backup What section in the following format: 

MSExchange-2010\Servername\MailboxStoreName\File 
MSExchange-2010\Servername\MailboxStoreName\Logs 
MSExchange-2010\Servername\PublicFolderStoreName\File 
MSExchange-2010\Servername\PublicFolderStoreName\Logs 
 
MSExchange-2007\Servername\StorageGroupName\MailboxStoreName 
MSExchange-2007\Servername\StorageGroupName\PublicFolderStoreName 
MSExchange-2007\Servername\StorageGroupName\Logs 
 
MSExchange-2003\Servername\StorageGroupName\MailboxStoreName 
MSExchange-2003\Servername\StorageGroupName\PublicFolderStoreName 
MSExchange-2003\Servername\StorageGroupName\Logs 

 

Functionality: ZCB performs VSS based backup of Store database files (.edb & .stm), transaction logs and 
checkpoint file for all the Mounted Storage Groups. The Exchange server transaction logs are purged 
after full and incremental backups of Exchange server. They are not purged after differential backups. 
An event is logged in the Windows Application Event Logs. 

Requirements :  

• The Volume Shadow Copy Service must be enabled. Although the Volume Shadow Service is 
enabled by default, it may have been turned off after Windows installation. Please refer to the 
Requirements section to know how to do this. 

•  Run the command vssadmin list writers at the Windows command prompt and check that the 
state of the Exchange Writer is stable. If not (or if there are any VSS errors), restart the 
Microsoft Exchange Information Store Service. 

• Latest Exchange service pack must be installed. For example: Exchange 2003 Server Service Pack 
2 or later must be installed. 

• In case of Windows 2003 Small Business Server edition, the Exchange Writer is disabled by 
default. Please follow the instructions this MS knowledgebase article to enable the Exchange 
Writer: http://support.microsoft.com/kb/838183 

• Make sure that the Exchange Storage Groups are in Mounted state. 
• Microsoft .NET Framework 3.5 Service Pack 1 must be installed on the ZCB machine. For 

Exchange 2010 server running on Windows 2008 Server R2 release, .NET 4.0 is required. 

http://support.microsoft.com/kb/838183
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• Exchange circular logging must be disabled. If circular logging is enabled, the Exchange server 
client will only retain the last 5 transaction logs, which may not be sufficient to restore to the 
most recent backup. 

Microsoft SharePoint 
Overview:  

ZCB supports back up MS SharePoint versions such as SharePoint 2010, MOSS 2007 and WSS 3.0.  

To configure MS Sharepoint server backups, create a new backup set and choose Sharepoint from the 
dropdown list in the Backup What section. ZCB backs up SharePoint data that is stored in the SQL 
database & application web site files, such as: 

• Configuration and Admin databases  
• Content and configuration data for Web Applications (Eg: C:\Program Files\Microsoft 

Office Servers\14.0\Data\Office Server\Applications)  
• Any third-party databases that are registered with SharePoint 
• Shared services databases in SharePoint 
• Office Search & Help Search index files  

 
Functionality:  

• ZCB performs full & differential backups of the SharePoint data incrementally backed up based 
on the modification time. The ZCB does not support transaction log based backup. 

• Since ZCB supports VSS based backup, SharePoint backup of individual objects such as Site 
collection, Web site, List/Document library, Document library folder, Document library file, List 
item, Version is not supported. Therefore files such as the SharePoint installation directory, IIS 
metabase information, Website application pool directory, etc require separate backup set 
configuration for backup. 

• ZCB currently supports only single server farm (standalone) configuration. In other words, the 
front-end server and the database server must reside on the same machine. 

Requirements:  

• The Volume Shadow Copy Service must be enabled. Although the Volume Shadow Service is 
enabled by default, it may have been turned off after Windows installation. Please refer to the 
Requirements section to know how to do this. 

• Windows SharePoint Services VSS Writer service must be enabled and running. To enable and 
run the SharePoint writer follow the steps described in  http://msdn.microsoft.com/en-
us/library/bb447591.aspx.  

• The SharePoint VSS writer depends on following VSS writers. All these VSS writers must be 
present and enabled on the Amanda client. 

• MS SQL VSS writer should be present 
• For Sharepoint 2010 

http://msdn.microsoft.com/en-us/library/bb447591.aspx
http://msdn.microsoft.com/en-us/library/bb447591.aspx
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o "SPSearch4 VSS Writer" is dependent on "SharePoint Foundation Search V4" 
service. 

o "OSearch14 VSS Writer" is dependent on "SharePoint Server Search 14" 
service. 

• For SharePoint 2007 
o "OSearch VSS Writer" is dependent on "Office SharePoint Server Search" 

service. 
o "SPSearch VSS Writer" is dependent on "Windows SharePoint Services Search" 

service. 
• Windows SharePoint Services VSS Writer service must run under the admin app pool account, 

which is the Network Service account in a basic installation of Windows SharePoint Services. 
 

 
Windows System State 
Overview:  

Windows System State refers to a collection of several key operating system elements and their files. 
Backing up the Windows System State is crucial for a successful disaster recovery strategy. ZCB can back 
up the Windows System State of all supported Windows platforms.  

Functionality:  

ZCB supports backup of Windows System State and performs VSS based backup of Boot files, System 
files, IIS, COM+ database, Registry, Active Directory and Certificate Server. Windows System State is 
always a full backup.  

 For Workstations 

Workstation in this context means any Windows XP machine or any Windows Vista or Windows 
2003 server machine which does not have Active Directory (AD). 

• Boot Files: 
o On Windows XP and Windows 2003: SystemDrive\NTDETECT.COM, 

SystemDrive\ntldr, SystemDrive\boot.ini (SystemDrive is usually c:). 
o On Vista: SystemRoot\boot directory (SystemRoot is usually c:\windows) 

• Catalog files: SystemRoot\System32\CatRoot\. 
• MachineKeys Files: SystemRoot\System32\Microsoft\Protect\* and 

AllUsersProfile\ApplicationData\Microsoft\Crypto\RSA\MachineKeys\* where 
ALLUSerProfile is c:\Documents and Settings\All Users. 

• Performance counters: perf*.dat and perf*.bak files in c:\windows\system32 on all OSs. 
• WFP files: All dll and exe files that come under Windows File Protection (WFP). Usually 

the dll files reside in c:\windows\system32 
• IIS metadata file if IIS is installed (applicable to all OSs). 
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• Certificate Database (Applicable to only Windows 2003 server that are Certificate 
Servers): files in c:\windows\system32\certsrv 

• COM+ registration database. 
• Registry: System, default, SAM, Security and Software files in 

SystemRoot\system32\config and additional Components and Schema files in Vista. 
 

 For Domain Controllers 

A Domain Controller (or DC) is any Windows 2003 machine with Active Directory installed.  

• DC backups include all of the state information listed above for Workstations. 
• In addition, the backups include Active Directory database, log files, and Group 

Policy Objects (GPOs). 

Requirements:  

• Please check the operating system and service pack requirements as mentioned in the 
Requirements section. 

• The Volume Shadow Copy Service must be enabled. Please refer to the Requirements section to 
know how to do this. 

 

MySQL Server 
Overview:  

ZCB supports logical back up MySQL Server versions 5.0 and 5.1.  

To configure MySQL server backups, create a new backup set and choose MySQL Server from the 
dropdown list in the Backup What section. Here, please specify the MySQL server information and user 
credentials of the user that can perform the backup. MySQL client path refers to the directory where the 
mysql client utilities compatible with your MySQL server are present. After filling in the details, click on 
the Discover button so that ZCB can connect to the MySQL server and find out the databases and tables 
present in it. 

 
Functionality:  

• Only full backups of MySQL servers are supported currently. ZCB doesn’t backup MySQL binary 
logs. 

• ZCB supports backup of specific MySQL databases. 
• ZCB supports backup of specific tables only from one MySQL database. It does not support 

selecting specific tables from multiple MySQL databases. 
• You can either backup a local MySQL server or a remote MySQL server. 
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Requirements:  

• The MySQL user specified in Backup What section should have sufficient privileges to perform 
logical backup from the ZCB machine. The minimal set of privileges required are: 
For backup:  
    LOCK TABLES, SELECT, FILE, RELOAD, SUPER, UPDATE, TRIGGER, SHOW VIEW  
For restoration:  
    CREATE, DROP, INDEX, SHUTDOWN, INSERT, ALTER, UPDATE, TRIGGER, SUPER, REPLICATION 
CLIENT, CREATE VIEW     

• MySQL client utilities (mysqldump and mysql) must be installed on the ZCB machine and the 
MySQL client version must be compatible with MySQL server. 
 

 

Monitoring 
The Monitor page displays the status of backups, restores, uploads and downloads operations in 
progress for all backup sets. Please note that Monitor page shows only the most recent in-progress task 
for a backup set. 

Depending on the type of an operation, you can take certain actions on it. For instance, you may want to 
stop any ongoing task, or may want to pause an upload operation to reduce network bandwidth usage 
during peak office hours. 

The summary of available options, for each type of operation is below. 

Operation   Option Stop Pause Resume 

Backup to Cloud Yes Yes Yes 

Backup to Disk Yes No No 

Upload to Cloud Yes Yes Yes 

Download Yes No No 

Restore Yes No No 

 

 Please note that if you are resuming an upload job, ZCB will also resume any incomplete upload jobs pending for that 
backup set. If you wish to resume only one job, please use the Report page. 

 

Reporting 
The Report page displays a table of various historic operations performed by ZCB. This page allows 
following two basic functionalities: 
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Viewing Reports 
You can click on any column heading to sort by that field.  

ZCB allows you to customize your views. Please click on Define Template button, specify the template 
name and choose the columns which you want to include the template view. Click on Save Template to 
add this new template.  

To load a specific template, you can select it from the dropdown just next to the Define Template 
button. 

To export your loaded template view to a Comma Separated Values (CSV) file, please click on the Export 
Report button. This file can be used for printing, or import into other applications to create 
spreadsheets and charts.  

Task Management 
You can select a backup/upload report and use right click to perform operations on the backup job. Here 
is a summary of what actions are allowed on what type of jobs. 

 

Job   Action Delete Backup Run Delete Failed 
Uploads 

Upload to Cloud 

Backup to Cloud Yes Yes No 

Backup to Disk Yes No Yes* 

Upload from Disk Yes Yes No 

Download Yes No No 

Restore Yes No No 

 

* Available only if data from disk is not uploaded already 

Please note that if you select multiple tasks the only action available is “Delete Backup Run” which will 
delete the entry from the ZCB tables. 

Restore 
ZCB offers a number of ways to restore file system and application backup. You can restore to the 
original backed up system or a different system altogether.  

Overview 

What is a Backup Catalog? 
When ZCB backs up data, it stores some key meta-information in a special file called the backup catalog. 
This catalog is used by ZCB at restoration time to let the user select the desired specific data for 
restoration and to restore the backup data correctly. 
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Restore to the original machine 
This is the most common case where one wishes to restore data to the same machine where it was 
backed up. To do this, you need to go to Restore page and follow the below-mentioned instructions as 
applicable for the type of backup data you wish to restore. 

Restore to a different machine 
You can also restore backup data originating from one machine to a different machine. This is mostly 
used to create a clone of the original system as done in a bare-metal recovery scenario. Doing this 
requires some additional steps before you can launch the actual restore process. The steps are: 

• It is recommended that you install the same Windows Operating System (with the same service 
packs) on the restore machine as was installed on the original machine. 

• Install ZCB on the target machine (where you wish to restore the backup data). 
• Import cloud certificate as described in section above. 
• Complete the process of restoring the catalogue as described in the section Restoring the 

Backup Catalog 
• Once the backup catalog has been downloaded by ZCB successfully, you can follow the normal 

restoration steps as explained in the Performing Restores section as applicable for the type of 
backup data you wish to restore. 

Windows File System 
Overview: For Windows File System restores, ZCB offers a lot of finer options to allow the user to have 
just the right control and flexibility while restoring the data. You can restore to the original backed up 
system or a different system altogether. 

Functionality:  

To perform restore of file system data, please follow the following steps: 

• In the ZCB user interface, select the backup set for which backup was taken and please navigate 
to the Restore page and from the table showing all the backup runs, click on the run which you 
want to use for restore.  

• In the Restore Point dropdown, ZCB will show you all the relevant backup images for this restore 
operation. The restored data will be exactly same as it existed at the time stamp contained in 
the backup run images. 

• Once you select a restore point, all the files which are available for restore will be shown by ZCB. 
• ZCB lets you select directories and files from a browser tree. You can use the Filter option to 

search specific files/folders. ZCB supports wild cards in the Filter specification. Wild cards "*" 
(match one or more character) and "?" (match exactly one character) are supported. You can 
either enter absolute path of the files to be searched. In case you do not remember the absolute 
path, use “*Filename*” pattern. Example, to search all files with .jpg extension, enter “*.jpg”. To 
search all files under “C:\Windows\System32”, enter “C:\Windows\System32” or “*System32*” 
as the search pattern. 
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• Now you can specify the following: 

Run Script Before Restore: This optional field lets you specify an executable file (example .bat 
and .exe) which you want to run just before the actual restore is performed. 

Run Script After Restore: This optional field lets you specify an executable file (example .bat and 
.exe) which you want to run just after the actual restore is performed. 

Download Folder: This path refers to the location where ZCB should download the backup 
archives from the cloud. 

Restore Folder: This optional field is required if you wish to restore the selected files and folders 
to an alternate location and have selected the Alternate Location radio button just below this 
field. 

Restore to Alternate Location: If selected, this radio button directs ZCB to write restore data to 
a location as defined in the Restore Folder field above. 

Restore to Original Location: If selected, this radio button directs ZCB to write restore data to 
the original location. If this is chosen, you would want to carefully choose the correct conflict 
resolution option in the Restore Policy dropdown just next to this field. 

Restore Policy: ZCB offers 4 conflict resolution options if it encounters a file already present in 
the folder where restore data is being written. These options are: 

Keep Original: This will make ZCB retain the already present file and skip the restore for it. 

Overwrite Original: This will make ZCB overwrite the already present file with the version 
contained in the restore data. 

Rename Original: This will make ZCB rename the already present file with a timestamp suffix 
appended to its original name. The file contained in the restore data will be restored with its 
name being intact.  

Rename Restored: This will make ZCB retain the already present file and the file contained in 
the restore data will be restored with a timestamp suffix appended to its original name.  

Retain Download Archive: By default, once the restore is complete, ZCB will delete the backup 
archive downloaded from the cloud. If you wish to retain this archive so that you can do more 
restores from this backup run later, you can select this option. Please note that you will have to 
manually delete the downloaded archive when you no longer need it. 

Requirements: 

• If you are attempting to restore data to a different machine than the one which was backed up, 
please complete the steps described in the Restore to a different machine section above. 
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• For file system backups, you can restore files from a different Windows operating system to a 
different Windows operating system. For e.g. you can restore files from a machine running 
Windows XP to a target machine running Windows 7. 
 

Microsoft SQL server  
Overview: ZCB supports Simple Recovery Model, Full Recovery Model and Bulk Recovery Model for SQL 
server databases. You can restore to the original backed up system or a different system altogether. 

Functionality:  

 Restoration to Original location:  

If selected, this radio button on the Restore page directs ZCB to write restore data to the original 
location. Please note that:  

• ZCB performs a VSS based SQL restore.  
• During restore of master database, SQL server is stopped and is restarted after restoration. 

 
 Restoration to Alternate location 

If selected, this radio button on the Restore page directs ZCB to write restore data to an 
alternate location as defined in the Restore Folder field above. Please note that: 

• The database files from the backup are copied to this alternate location.  
• SQL recovery is not performed and SQL services are not stopped.  

Requirements: 

• Please make sure that the SQL installation and database locations match with the location 
during backups.  

• If you are attempting to restore data to a different machine than the one which was backed up, 
please complete the steps described in the Restore to a different machine section above. 

• You must install the same Windows Operating System (with the same service packs) on the 
restore machine as was installed on the original machine. 

• The SQL writer service must be running at the time of backup and recovery. Microsoft 
recommends that the SQL VSS Writer service be automatically started. MSDE writer is not 
sufficient for backup and recovery. 

• The amandabackup user must be added as a SQL server user with sufficient privileges. To add 
the user in SQL server Management Studio, click on Security > Logins > Add New Login. Add the 
amandabackup user account and give it privileges. You can just add it to sysadmin server role.  

• If you wish to restore a deleted database, please follow this procedure: 
o Restore the Master and the deleted database from the latest Full backup. 



465 S. Mathilda Ave., Suite 300 • Sunnyvale, CA 94086 • 1-888-496-2632 • www.zmanda.com 
 

o Once the restore is successfully completed, use the "All latest” filter on the Restore 
Point dropdown on the Restore page and select the deleted database from all the 
backup runs including the latest Full backup.  

o After the restore is successfully completed, attach the restored database using SQL 
Management Tool. 

 

Microsoft Exchange Server 
Overview: In the event of a server loss, how you perform the recovery will depend on the server role 
and your disaster recovery plan. One would also need to recover Exchange databases in case of issues 
such as database corruption, loss of transaction logs, accidental deletion of mailboxes, etc. Using ZCB, 
exchange databases can be restored to the same server or to an alternate server depending on the 
Disaster Recovery plan decided by the Exchange Administrator.  

Functionality: Three types of recovery operations are allowed by Microsoft Exchange:  

• Roll-forward,  
• Point in time  
• Full restore  

The state of the MS Exchange server when the restore is started determines what type of recovery will 
be available. Please see this Microsoft documentation for details on Exchange recoveries. You can 
restore Exchange 2007 backups to a recovery storage group and Exchange 2010 backups to a recovery 
database. 

When the storage group is mounted, the Exchange store automatically replays any pending transactions using the Exchange 
Server soft recovery feature. Therefore all restores performed through the Zmanda Cloud Backup are always "roll-forward" 
restores. 

 Restoration to Original location: In case of Exchange database corruption or loss of the 
transaction log, an Exchange Administrator would want to restore the backed up data to the 
original server. Ensure that all the requirements listed below are satisfied before starting the 
restore. The steps to restore an Exchange server data to original location are: 

• Navigate to the Restore page on ZCB user interface. Select the backup and point in time that 
you want to restore.  

• Select the Mailbox Store Database or Public Folder Database & its associated Logs from the 
File List view. 

• Select the radio button - "Restore to Original Location." ZCB will restore the data to the 
same location from where the backup was made. 

• From the drop down select – “Restore Policy: Overwrite Original”. Once confirmed, click 
Restore to start the restore process.  

 

http://msdn.microsoft.com/en-us/library/ms986586.aspx


465 S. Mathilda Ave., Suite 300 • Sunnyvale, CA 94086 • 1-888-496-2632 • www.zmanda.com 
 

 Restoration to Alternate Exchange Server: There are two reasons to restore to a different 
machine than that from which the backup was taken:  
1. A disaster has destroyed the original hardware. You must restore the database to a rebuilt 

Exchange Server or to an alternate Exchange server.  
2. You are recovering an individual mailbox. In this case, there are additional steps to apply the 

recovery to the production Exchange server (see the next section below). 

The steps to restore an Exchange server data to an alternate Exchange server are: 

• Navigate to the Restore page on ZCB user interface. Select the backup and point in time that 
you want to restore.  

• Select the Mailbox Store Database or Public Folder Database & its associated Logs from the 
File List view. 

• Select the radio button - "Restore to Original Location." ZCB will restore the data to the 
same location from where the backup was made. In case of a Recovery Exchange server, the 
data will be restored to the newly created Mailbox/Public Folder store. 

• From the drop down select – “Restore Policy: Overwrite Original”. Once confirmed, click 
Restore to start the restore process.  
 

 Restoration to Recovery Storage Group/Database: Exchange server provides an option to 
restore to a Recovery Storage Group & Recovery Database respectively. Using Recovery 
Databases, users can restore the Mailbox store to a production Exchange server without having 
to dismount the Mailbox stores from where the backup was taken.   
Restoring to a Recovery Storage Group/Database is not supported for Exchange 2003. 

 
The steps to restore an Exchange server data to a Recovery Storage Group/Database are: 

• Navigate to the Restore page on ZCB user interface. Select the backup and point in time that 
you want to restore.  

• Select the Mailbox Store Database & its associated Logs from the File List view. 
• Select the radio button - "Restore to Recovery Database". Enter the name of the “Recovery 

Database”. ZCB will restore the data to the location where the Recovery Database is 
created. 

• From the drop down select – “Restore Policy: Overwrite Original”. Once confirmed, click 
Restore to start the restore process.  

 

Requirements: 

• The databases must be in the Dismounted state and the This database can be overwritten by 
restore option enabled through the Exchange System Manager (Exchange 2003) or Exchange 
Management Console (Exchange 2007, Exchange 2010).  

• Enable the Exchange Server Certificate in case it is not enabled. 
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[PS] C:\Windows\system32>get-exchangecertificate 
Thumbprint    Services   Subject 
----------    --------   ------- 
18DDD379D721792012001D294F342FF8380A61F1  IP.WS.     CN=Ex-2010 
 
[PS] C:\Windows\system32>enable-exchangecertificate 
cmdlet Enable-ExchangeCertificate at command pipeline position 1 
Supply values for the following parameters: 
Services: IIS 
Thumbprint: 18DDD379D721792012001D294F342FF8380A61F1 
 

• Once the Exchange server certificate is enabled, go to Start > Run. Type mmc. Add Snap-in for 
Certificates > Computer Account. Copy the certificate with Friendly Name as Microsoft 
Exchange from Personal > Certificates to Trusted Root Certification Authorities. 

• If you are performing restores to a Recovery Storage Group/Database, please create an empty 
Recovery Storage Group/Database on the Exchange server. 

• Additional steps for Exchange 2007:  
o Install .NET v2.0 SP1. Install the patch for Powershell depending on the Windows OS 

platform from the link http://support.microsoft.com/kb/968929 
o Add amandabackup user to the Exchange View-Only Administrators group. Then restart 

ZWCService. 
• Additional steps for Exchange 2010: 

o Install .NET v4.0. 
o Add amandabackup user to View-Only Organization Management group 

using Exchange Powershell as follows: 
Add-RoleGroupMember "View-Only Organization Management" -
Member amandabackup 

 
o Set AllowUnencrypted flag to True using the commands below. AllowEncrypted is 

defined on the client end, via the WSMAN: drive. You must be running powershell.exe 
(or powershell_ise.exe) as an elevated process. 
ps> cd WSMan:\localhost\Client 
ps> dir 
Name                      Value 
-----------               ------------ 
NetworkDelayms            5000 
URLPrefix                 wsman 
AllowUnencrypted          false 
Auth 
DefaultPorts 
TrustedHosts 
ps> set-item .\allowunencrypted $true 

 

http://support.microsoft.com/kb/968929
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o Open IIS Manager. Under Exchange Computer Name > Sites > Default Web Site >  
PowerShell, click on Authentication. Change Basic Authentication to Enable. 
 

Additional Requirements (for restores to an alternate Exchange Server) 

• Please complete the steps described in the Restore to a different machine section above. 
• The target Exchange version and service packs must be the same as the source server. For 

example: Exchange 2003 Server Service Pack 2 or later must be installed. 
• Exchange must be installed and must have the same Organization and Administrative Group 

name as the source server.  
• The storage groups and databases must already exist on the target server, and have the same 

names as the original storage groups or databases.  
• Because you are restoring to an alternate "recovery server" that has a different set of log files, 

the signatures on the log files must match. To ensure this, either rename the E0x.log file located 
in the Transaction log directory, or enable the Do not mount the database option while creating 
a Mailbox or Public folder store.  

• The Volume Shadow Copy Service must be enabled. Although the Volume Shadow Service is 
enabled by default, it may have been turned off after Windows installation. Please refer to the 
Requirements section to know how to do this. 

•  Run the command vssadmin list writers at the Windows command prompt and check that the 
state of the Exchange Writer is stable. If not (or if there are any VSS errors), restart the 
Microsoft Exchange Information Store Service. 

• In case of Windows 2003 Small Business Server edition, the Exchange Writer is disabled by 
default. Please follow the instructions this MS knowledgebase article to enable the Exchange 
Writer: http://support.microsoft.com/kb/838183 

• Microsoft .NET Framework 3.5 Service Pack 1 must be installed on the ZCB machine. For 
Exchange 2010 server running on Windows 2008 Server R2 release, .NET 4.0 is required. 

• Exchange circular logging must be disabled. If circular logging is enabled, the Exchange server 
client will only retain the last 5 transaction logs, which may not be sufficient to restore to the 
most recent backup. 

 

Microsoft SharePoint 
Overview: ZCB supports Content Recovery, Web Application Recovery and Disaster Recovery for MS 
SharePoint. You can restore to the original backed up system or a different system altogether. 

Functionality:  

 Content Recovery 

Content recovery applies to being prepared for accidental updates or deletions of data, usually 
by end users such as deleting documents, tasks, calender items, etc. Content recovery can be 
done by restoring Web application's Content databases. Since, ZCB does not support Roll-

http://support.microsoft.com/kb/838183
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forward restore, if the restore is targeted to the original location, changes done after backup will 
be lost. So, one can restore the respective Web application's content databases to alternate 
location and use Third Party tools to extract the required object. 

 Web application Recovery 

A web application recovery would be required in case of accidental deletion or corruption of the 
content databases, etc. To recover a deleted/corrupted web application's content database to 
Original server, select the appropriate database files from SharePoint server backup. 

 Restoration to Original location: ZCB performs the restore to original location in following 
steps: 

• During pre-restore operations, the following SharePoint services are stopped: 
- Windows SharePoint Services Administration   
- Windows SharePoint Services Search  
- Windows SharePoint Services Timer  
- Office SharePoint Server Search  
- IIS Admin Service (if entire farm is being restored)   

• The selected SharePoint database/s and log file/s are restored to their original location. If all 
the data is selected from the Restore What page, all the databases and Index search files are 
restored. You can also select individual content databases to restore. 

• During the post restore phase, the ZCB calls the SharePoint VSS writer post-restore 
operation which automatically detaches and then reattaches each database to the farm. 
This synchronizes the respective databases with the SharePoint farm.  

• The services which were stopped before the restore operation are restarted.  
 

 Restoration to Alternate location: When restoring to an alternate location, services are not 
stopped and started before and after restore. Also, the SharePoint Writer's port-restore 
operation is not called. The selected databases and log files are simply restored to the given 
location. 

Requirements: 

• If you are attempting to restore data to a different machine than the one which was backed up, 
please complete the steps described in the Restore to a different machine section above. 

• The target server must have the same SharePoint server (WSS 3.0 or MOSS 2007 or Share Point 
2010) with same Service Packs and SQL server (embedded SQL server or SQL server 2008 or SQL 
server 2005 or SQL server 2000). 

• Make sure that MS SharePoint is installed in the same location as when the backup was run. The 
databases and log file locations should also match the original configuration. 
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• The Share Point Databases must be in stable state. To check the state of the SQL server, Connect 
to the SQL server using MS SQL Management Studio. The Properties from right click menu for 
each database will display the state. The state of the database must be Normal. 

• Please make sure that the following services are in the Started state 
- Windows SharePoint Services VSS Writer 
- Volume Shadow Copy 
- Windows SharePoint Services Tracing  

 
Windows System State 
Overview: ZCB offers recovery of Windows System State on all the supported Windows platforms.  

Functionality: ZCB supports backup of Windows System State and performs VSS based backup of Boot 
files, System files, IIS, COM+ database, Registry, Active Directory and Certificate Server. Windows 
System State is always a full backup.  

Please note that for system state restores, ZCB will set default values which are different from those of 
other applications. It will set the Restore to option to Original Location and the Restore Policy option to 
Overwrite Original. 

Requirements:  

• You must install the same Windows Operating System (with the same service packs) on the 
restore machine as was installed on the original machine. 

• If you are attempting to restore data to a different machine than the one which was backed up, 
please complete the steps described in the Restore to a different machine section above. 

• The Volume Shadow Copy Service must be enabled. Please refer to the Requirements section to 
know how to do this. 

MySQL Server 
Overview: The Restore page for a MySQL backup set presents users with 2 views namely Databases and 
SQL Files. To select databases, use the Databases view. ZCB allows selecting individual databases but 
does not support selecting individual tables for restore. The SQL Files filter shows the backup.sql 
containing SQL commands.  

Functionality: The same MySQL server information and MySQL user credentials for the backup set (as 
configured in the Backup What page) is used for restoration.  

The steps to restore MySQL database or tables to the Original server are: 

• Navigate to the Restore page on ZCB user interface. Select the backup run you want to 
restore from.  

• Use the Databases view and select the databases to be restored.  
• Click on Restore. 
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• The backup image containing SQL commands is restored to the Restore Location specified in 
Restore page.  

• The Policy in the Restore page is applied to the files in this location (not MySQL 
databases/tables).  

• The mysql client command is then used to execute the SQL commands that are in the 
backup image. ZCB will restore the selected databases or tables to the MySQL server from 
where the backup was taken from. 

 

The steps to restore the MySQL backup file are: 

• Navigate to the Restore page on ZCB user interface. Select the backup and point in time that 
you want to restore.  

• Use the SQL Files view and select the backup.sql file and its folder. 
• Click on Restore.  
• When MySQL file is restored using this procedure, no MySQL recovery is performed.  
• The MySQL backup image contains sequence of MySQL commands that can bring the 

database back to original state. Restoration of the backup.sql file allows users to edit the 
SQL commands and run a manual recovery as needed. 
 

Requirements:  

• The MySQL user should have necessary privileges to perform MySQL operations that the backup 
image contains.  

• Restoration process requires MySQL client commands to be installed on ZCB machine and it 
must be compatible with the MySQL server version. MySQL server must be running for 
restoration to be successful. 

 

Disaster Recovery 

Disaster recovery refers to restoring the system and data in the event of partial or complete failure of a 
computer because of natural or technical causes. Following sections explain how to prepare for Disaster 
Recovery of any application server running Microsoft SQL server, Microsoft Exchange server, Microsoft 
SharePoint server or any File server and then how to recover the system in case of a disaster. 

Preparing for Disaster Recovery 

To protect an application Server from a disaster, one should perform backups of its critical components 
like System State, application data like databases, application installation directories, etc. We 
recommend users to create backup sets for such critical components like: 
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• System Drive (default: C:\) - Exclude all system and temporary files. This is drive where the 
Windows operating system and all applications are installed. 

• System State - Backup of the server’s registry, boot files, COM+ database, Active Directory, etc.  
• Application data – Application data backup like Microsoft SQL server, Microsoft Exchange 

server, Microsoft Sharepoint server.  
• Application installation directory - if the application is installed on a drive other than the 

System drive, include the installation directory. You can exclude the Database directory since it 
will be backed up as a part of SQL server database backup. 

• User Data - Backup of File server data on partitions other than the System drive. 

Performing Disaster Recovery 

• Install the same version of Windows server and Service Packs as the original server. Make sure 
that the new server has exact same drive partitions, Windows installation directory and 
Computer Name as the original server. Do not put the machine in any domain or Workgroup. 

• Log in to the machine as an Administrator. 
• Install Zmanda Cloud Backup in the same directory location as the original server. 
• Since you are attempting to restore data to a different machine than the one which was backed 

up, please complete the steps described in the Restoring the Backup Catalog section to 
download the catalog of backup sets uploaded from the original server. Restart the ZCB UI upon 
a successful completion of Restore Catalog procedure. 

• Activate the backup sets using File Menu > Activate Backup Set.  
• Click on the System drive backup set. Navigate to the Restore page on ZCB user interface. Select 

the backup and point in time that you want to restore.  
• Select the radio button - "Restore to Original Location" ZCB will restore the data to the same 

location from where the backup was made. 
• From the drop down select – “Restore Policy: Overwrite Original”. Once confirmed, click 

Restore to start the restore process.  
• The restore of the System drive may report errors since it will be unable to restore the Windows 

system files. You can safely ignore failure for such system & open files. 
• After the System drive data has been successfully restored, restore the data for System State 

backup set with similar restore settings as above.  
• The next data to be restored is for the Application installation directory & User Data backup 

sets with similar restore settings as above. 
• Now reboot the server. 
• After the server is rebooted, go to the Windows Services and check if the application services 

are installed and in a running state. 
• Once the application services are confirmed as running, restore the Application data backup set. 

 

Administration 

Changing Thread Count 
Starting from version 4.0, ZCB allows users to configure the number of threads which will be used to 
upload/download the data to the cloud.  
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You can tweak the values in Preferences > Maximum thread Counts. If you increase the number of 
threads, the upload/download generally speeds up due to concurrent data transfers. However, please 
note that beyond a point the performance might not improve further, or it might even fall due to other 
overheads. 

Localization 
ZCB is available in three languages – English, German and Japanese. However to use file/folder name 
containing non English characters, you need to have the Windows edition for that language. For e.g. if 
you are using Japanese characters in file names to be backed up, you need to be running a Japanese 
edition of Windows operating system. 

Email Notification 
ZCB allows users to receive notifications when particular operations get completed. This control is 
offered both at the global level (for all backup sets) or at a backup set level. 

ZCB provides notification of backup and recovery events in two different methods: 

1. All events (successful and failure) are logged in the Windows event logs. Window event log 
analyzer tools can be used to filter the events and analyze them. 

2. Email notification can be sent when a particular event occurs. Success and Failure backup, 
upload, download and restore events can be sent as an email.  
 

To enable email notifications, you need to configure the mail server first. To do this, please click on 
Preferences > Email > Mail Server and provide information for these fields: 

• Outgoing SMTP Server: This is the ip address or hostname of your outgoing SMTP server. 
• Port: This is the SMTP server port which ZCB should connect to for sending emails.  
• Username: This is the email address/username which is to be used for authentication with the 

mail server. Password: This is the password for the above email account. 
• Authenticate: This check box is to be disabled if your SMTP server doesn’t need authentication. 

Else, please keep it enabled. 
• Secure: If you want the communication between ZCB and SMTP server to be over SSL rather 

than clear text, you can enable this checkbox. If you are using Exchange server, please enable 
Require TLS encryption option on the Exchange server. To configure Transport Layer Security 
Encryption for clients, please see Microsoft KB article http://support.microsoft.com/kb/829721 

• From: Please specify what mail id you would like ZCB to put in the From field of the emails. 

After entering correct values for above, you can test if ZCB can connect to the SMTP server by clicking on 
the Test Connection button.   

Once you complete the above steps, you have successfully configured mail server. Now, you need to 
define email recipients list and what events you wish to be notified about. You can do this at both global 
and backup set levels. 

http://support.microsoft.com/kb/829721
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Global Email Notifications 
To add a global email list which can be used across all backup sets, please click on Preferences > Email > 
Email Addresses and provide a list of email ids. Multiple email addresses can be specified separated by 
“;” (semi colon) character. If you don’t want to define this global email list, you can skip this setting. 

Once you add this list and have a working mail server configuration, by default ZCB starts sending 
notification of all success/failure events to this global email list. If you wish to modify this behavior at 
the backup set level, please refer to the Backup-set Specific Email Notifications section below.  

Backup-set Specific Email Notifications 
You can also control the email notification behavior at the backup set level and define what events and 
email-ids are used for notification by ZCB. 

To do this, select the backup set from the left hand pane and go to Backup page. In the Backup When 
section, under the Backup Set Preferences tab, you can provide the value of following fields:   

Notify:  In this option field, you can specify email addresses which are specific to this backup set. Like 
before, multiple email addresses can be specified separated by “;” (semi colon) character. 

Also notify recipients specified in email preferences: By default, this check box is enabled which means 
that ZCB includes the global email list (as defined in the Global Email Notifications section above) in the 
notification emails generated by it. You can disable this checkbox, which will make ZCB send emails to 
only the email addresses defined in the Notify field above. 

Event types: You can enable or disable checkboxes defining each event type for which you want to 
generate email notifications. 

An example email reporting Upload success for backup set BackupSetSystemState running on server  

Demo : 
subject:[ZCB:demo2] Upload Report 
Upload of backup set "BackupSetSystemState" is successful. 
Upload start time : 2009/11/09 16:28:00 
Upload end time : 2009/11/09 16:48:14 
Upload Rate : 1448 Kbps 
Bytes uploaded : 214.58 MB 
Error Details: No upload error 

HTTP Proxy Server 
ZCB supports connecting to internet via a HTTP proxy server. To setup this, please go to Preference > 
HTTP Proxy Server. Here you can specify your proxy server’s hostname in Proxy Host field and the proxy 
server’s port number in Proxy Port field. Please note that HTTP version 1.1 should be supported by the 
proxy server for ZCB uploads to work. 
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If ZCB can’t connect to the internet using this HTTP proxy server then the uploads will fail with Storage 
Cloud Communication error.  

 

Upgrading ZCB 
To check whether there is a new ZCB version available, please go to Help > Check for ZCB Updates. You  
will be taken to the ZCB release page on Zmanda Network from where you will be able to download the 
new version, if available. 

After downloading, run the installer. Choose yes when the installer asks whether you wish to upgrade. 
This will preserve your ZCB configuration and backup data. 

 

Reinstalling ZCB 
If for some reason, you wish to reinstall ZCB on the same machine, you can do so by following these 
steps: 

1. Click on Windows Start > All Programs > Zmanda > Zmanda Cloud Backup > Uninstall on the 
ZCB machine to launch the uninstaller. 

2. If you wish to retain ZCB configuration and backup data on your machine, choose Yes when the 
uninstaller asks you this question.  

3. In case you encounter uninstallation issues and wish to clean the ZCB state completely, follow 
the steps mentioned in the section below. 

4. Run the ZCB installer again and complete the installation. 

 

Cleaning up ZCB installation 
If you are trying to uninstall ZCB and facing trouble, then please follow the following steps to clean up: 

1. Locate the ZCB installer (.exe) which you downloaded from Zmanda Network. 
2. Please right click on the installer and extract it as a zip archive using an archiving tool such as 

7zip.  
3. After extracting, open Windows command prompt and change to the extracted directory. Now, 

run one of these commands: 
 
ZCBInstallCleanUp.exe (If you wish to preserve ZCB data) 
ZCBInstallCleanUp.exe –D (If you wish to force delete the full ZCB installation)  
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Amazon S3 Cloud  

Checking the S3 Connection and Subscription 
To verify that S3 storage is available, choose Cloud > Check Amazon S3 Connection. This causes ZCB to 
connect to S3 and validate the purchased Amazon S3 certificate. You can use this test to validate your 
installation, or to troubleshoot failed uploads/downloads. 

Purchasing and Managing S3 Storage 
Choose Cloud > Purchase Subscription or Cloud > Manage Subscription to open a browser window that 
connects you to Zmanda Network and Amazon portal, where you can login to see the storage you have 
purchased, and purchase additional storage if desired. Zmanda Network account information and 
Amazon account information is required to access the information.  

Displaying billing information 
To track display a report that shows what you are spending on the cloud storage, click Cloud->S3 Billing. 
This takes the user to Amazon web site that provides detailed billing information for current month as 
well as prior month. Amazon account information is required. 

Importing Cloud certificate  
After purchasing Amazon S3 subscription, ZCB certificate will be available in your Zmanda Network 
account. Download the ZCB certificate from Zmanda Network to the ZCB machine. The ZCB certificate 
would be named s3.zmanda and must be imported into ZCB User interface using Cloud > Import Cloud 
Certificate menu option.  

There can be only one certificate installed for a ZCB installation. 

Restoring the Backup Catalog 
To restore data to a machine that was never backed up by ZCB (as in a "bare metal" recovery) requires 
that your first recover the backup catalog. First import the ZCB certificate as mentioned in the Importing 
the ZCB certificate section above. Now, to start the restoration of catalog, navigate to Tools > Restore 
Catalog where you can provide the values for the following: 

• Host Name: This refers to the host name of the original machine, without the domain name 
if any. For instance, if your original machine’s host name was myexchangeserver.xyz.com, 
please provide the host name as “myexchangeserver”.  

o If you don’t remember the original machine host name, then you can put the wild 
card * in this field.  This will download catalog for all the machines which were 
backed up using ZCB. 

o If you are performing catalog restore on the same machine as the original machine 
(and the hostname hasn’t been changed) then you can keep this field blank. ZCB will 
identify the hostname of the local machine and will download the catalog for that 
hostname.  

• Backup Set Name: This refers to the name of the backup set on the original machine when 
the backup was taken. If you wish to restore catalog for all backup sets (potentially matching 
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the above provided Host Name condition), you can keep this field blank. You can also use 
the wild card * to select matching backup set names. For e.g. exchange* will match all the 
backup set names such as exchangebackup, exchangeone, etc.  Please note that the backup 
set name field is case sensitive.  

• Restore Location: If you wish, you can provide a temporary location on the local machine 
where restore catalog will be created by ZCB.  

This will make ZCB query the Amazon S3 storage and download the backup catalog. After this, you can 
browse backup sets, backup reports and perform data recovery. 

 Please note that if there is no backup data available on the cloud (after expiry of retention period or otherwise), you will 
not be able to recover either backup data or backup set configuration using this procedure. 

Moving local backup data to a different location on the same machine 
If you have been using ZCB to keep backup data on your local disk and now wish to move this old data to 
a new location on your machine (a different drive for instance), you can do so. For this, you will have to 
use the movebackup option of zwcontroller.exe program which ships with ZCB. 

The syntax for this command is: 

<ZCB Installation Folder\bin>zwccontroller.exe movebackup <BackupSet> 
<BackupFolder> 
 

Here,  

• ZCB Installation Folder refers to the location where ZCB has been installed. By default, this 
location is C:\Program Files\Zmanda\Zmanda Cloud Backup.  

• BackupSet refers to the string – “ComputerName+BackupSetName”. So for instance if the 
backup set is MyDocuments and the computer name where ZCB is installed is 
zmandazcb.xyz.com, then the BackupSet string will be “zmandazcb+MyDocuments”. 

• BackupFolder refers to the complete path of the destination folder where the backup files are 
desired to be moved. 

For example, let’s assume that you have installed ZCB at the default location on a machine named 
“production-win2k3”. To move backup data belonging to backup set “My Exchange” to a new location 
“D:\ZCB-Backups” , the command would be: 

C:\Program Files\Zmanda\Zmanda Cloud Backup\bin>zwccontroller.exe movebackup 
“My Exchange+production-win2k3” “D:\ZCB-Backups”  

Please note the following for this operation: 

• If there is any ongoing backup or upload operation for the backup set, the command will fail. 
• You might also want ZCB to write new backup data to the new disk location. To do this, please 

change the Location field under the Local Storage heading in the Backup Where section. 
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Changing TCP Ports for use by ZCB 
ZCB uses TCP ports 10080 and 10081 for backups and restoration. If these ports are not available at the 
time of installation, next available ports are selected.  
ZCB also has the provision of changing the ports by using Tools > Advanced Options. One can specify the 
"Backup" and "Restore" ports and click on Save. 
ZCB services are restarted to apply these port changes. 

 
You can also specify the upload and download limits for each upload and download job in the ZCB. This 
value is applied across all backup sets. The throttle limit can overridden in the Backup How tab for the 
backup set. 

You can specify HTTP proxy server and port used if the ZCB machine needs a http proxy to connect to 
the Internet. If this value is not specified, the uploads will fail with Storage Cloud Communication error. 
HTTP version 1.1 should be supported by the proxy server for ZCB uploads to work. 

Changing Log Level 
Log files created by the ZCB program are stored in the \Debug directory installed along with ZCB 
(Typically C:\Program Files\Zmanda\Zmanda Cloud Backup\Debug). LogFile.txt is ZCB engine log file. 
ZIBLogFile.txt is the log file for the ZCB program itself. 

Log files for the installation and uninstallation process can be found in "%temp%" folder which is 
typically at "C:\Documents and Settings\<Logged_in_user>\Local Settings\Temp” for most systems. If 
not, it resides in the Windows Installation drive (D:, E: ...)under the same directory structure. 

ZCB installer creates a file named "ZCBInstallLog.log" as system-log of the installation process in the 
%temp% folder 

You can customize the amount of log messages ZCB generates. Generally, you would like to increase log 
level when you want to troubleshoot an issue or just before opening a support case with Zmanda.  

To change the log level, please go to Help > Change Log Level and choose one of Error, Warning and 
Debug. The value Debug makes the logging most verbose and value Error makes it the least verbose. 

Collect Logs 
If you run into a problem that requires assistance, navigate to Help > Collect Logs before contacting the 
Zmanda Support Team. This makes ZCB collect all the relevant files into an archive, displaying its name 
and location. Please be patient as collecting the logs can take a few minutes and attach the log file to 
your support request. Please note that 

• Collect Logs has to be run as a user with Administrator privileges. If ZCB UI is being run as a user 
who is not an Administrator on Vista, Windows 7 or Windows 2008 server, a user credentials 
dialog is popped up asking to enter Administrator or any other user name with Administrator 
privileges and password.  
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• In Windows XP and 2003 server, if ZCB UI is being run as a user who is not an Administrator, 
Collect logs will not work. You will have right click on the ZCB support short-cut and use Run as 
option and enter Administrator credentials.  

 

 

Trouble Shooting 
Installation  errors 
If you see this error - "User SYSTEM has previously installed an installation for product Microsoft Visual 
C++ 2008 Express Edition with SP1 -ENU. That user will need to run that installation again before using 
that product. Your current installation will now continue", it means that you would need to install Visual 
C++ redistributable library. Please right click the installer and extract it as a zip archive using an archiving 
tool such as 7zip. After extracting, go to the vcredit_x86 or vcredit_64 folder and run the exe program 
contained in it. This will allow you to uninstall this library. After uninstalling, please rerun the ZCB 
installer.  

If the problem is not resolved, you can collect ZCB log files and send them to us. The default location of 
the installer and uninstaller logs is C:\Program Files\Zmanda\Zmanda Cloud Backup\Debug. 

Uninstallation hangs 
If you find that the uninstallation is hung, please check that: 

• The ZCB user interface is not open by opening Windows Task Manager and checking if there is 
any javaw.exe process running. 

• No scheduled backups are running. For this, check if any of the ZCB processes - 
ZWCController.exe or AMZS3Controller.exe  - are running. 

• None of the ZCB’s processes, such as mysqld, etc. are being accessed by some other non-ZCB 
programs.  

If the problem is not resolved, you can collect ZCB log files and send them to us. The default location of 
the installer and uninstaller logs is C:\Program Files\Zmanda\Zmanda Cloud Backup\Debug. 

Error: “Run application using Administrator” while performing backup to 
cloud 
On Windows 7, the “backup to cloud” operation, which backs up data directly to cloud, requires 
administrator privileges.  If a non-administrator user launches ZCB & a “backup to cloud” operation is 
run, then the operation fails with error "Run application using Administrator". 

To fix this issue, you can do one of these two things: 
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• Launch ZCB user interface as the administrator user. 
• Schedule the “backup to cloud” operation rather than running it manually. The ZCB 

scheduled tasks run in the context of “system” user and hence this permission problem 
doesn’t affect them. 

Error: “Failed to write registry. Verify that Remote Registry service is 
running.” 
This error during ZCB installation. ZCB installer writes to the registry. If the Remote Registry Service is 
not running, the installer will fail with this error message and installation will be rolled back. Start the 
Remote Registry Service on ZCB machine before installation and run the installer again. 

 

Error: “Backup failed” 
This error appears when the backup failed for any of a number of reasons, such as snapshot failure or 
running out of physical volume extents. Before contacting the Zmanda Support Team, choose Collect 
Logs from the ZCB Tools menu. ZCB then collects all the relevant files into an archive, displaying its name 
and location. Be patient; collecting the logs can take a few minutes. Attach the log file to your support 
request. Zmanda Support may ask you to set the log level to Debug (Tools->Log level->Debug) when 
helping you troubleshoot. 

 

Error: Backup of a volume is already in progress 
ZCB allows parallel backups of different backup sets as long as they are set to backup different volumes. 
If this condition is not met, second backup job will fail with this error. Please note that this limitation 
doesn’t prevent you from doing backup of one volume while upload of a backup set containing the same 
volume is in progress after being backed up to local disk. 

Error: Application backup already in progress 
ZCB uses VSS snapshots to backup live application. To maintain data consistency, ZCB doesn’t allow 
concurrent backups of two applications such as SQL Server and Exchange. Please note that this 
limitation doesn’t prevent you from doing backup of one application while upload of another application 
is in progress after being backed up to local disk. 

To resolve this error, please make sure that two application backups don’t get executed in the same 
time duration. 

Error: Mismatch in backup set configuration. Please contact Zmanda customer 
support 
This error comes up when the backup set configuration is not saved or if the directory structure of 
selected files/folders being backed up has changed since the time backup set was first created.  
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To resolve this error, please click on the Refresh button in the Backup What section and then click on the 
“Save backup set” button in the Backup page. If you still see issue, please contact Zmanda support. 

Error: Backup root directory not found 
This error indicates either of the following:  

• An invalid/non-existent Backup Folder has been specified in the backup set.  

• ZCB lacks the necessary permissions on the directory.  

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB.  

Error: Backup Set directory not found 
This error indicates either of the following:  

• An invalid/non-existent Backup Folder has been specified in the backup set.  

• ZCB lacks necessary permissions on the directory.  

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB.  

 

Error: Cannot parse this index file 
This error indicates either of the following:  

• An invalid/non-existent Backup Folder has been specified in the backup set.  

• ZCB lacks necessary permissions on the directory. (Backup Folder)  

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB.  

 

Error: Cannot open index file 
This error indicates either of the following:  

• An invalid/non-existent Backup Folder has been specified in the backup set.  

• ZCB lacks necessary permissions on the directory.  

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
tab. Make sure that Backup Folders are present and accessible to ZCB.  
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Error: “Access denied” while performing backups 
This means the ZCB was not able to read/write the backup data due to insufficient access privileges. 
Please note that ZCB performs backup with the privileges of amandabackup user and hence please 
provide necessary privileges to it. For application backups, please refer to the Requirements section for 
that application in this user guide. 

However, if amandabackup user can’t be given required permissions for some reason then you make 
ZCB perform the backup using permissions of a different Windows user. To do this, please refer to the 
User Credentials section.  

Error: Restore failed 
There can be many reasons for a restore to fail. Before contacting the Zmanda Support Team, choose 
Collect Logs from the ZCB Tools menu. ZCB then collects all the relevant files into an archive, displaying 
its name and location. Be patient; collecting the logs can take a few minutes. Attach the log file to your 
support request. 

Error: Restore Catalog command failed. Please look in the log file for more 
details. 
The restore catalog command failed for any of a number a reasons, perhaps due to S3 connection 
problems or insufficient space on the local folder. Check the logs for further information.  

Error: Unable to create backup set Backup_set_name 
Check that the local disk has not run out of space.  

Error: Backup Set with name Backup_set_name already exists. 
Duplicate backup set names are not allowed. Please choose a different name.  

Error: Unable to create temp file 
Make sure that ZCB has permission to write to ZCB_installation_directory\misc.  

Error: Unable to save Backup Where parameters for backup set  
Make sure that ZCB has permission to write to 
ZCB_installation_directory\conf\Hostname+Backup_set_name.  

Error: Failed to save Backup What parameters for backup set  
Make sure that ZCB has permission to write to  
ZCB_installation_directory\conf\Hostname+Backup_set_name .  

Error: The format of the restore time not correct. 
Restore time must be specified in HH:MM format.  
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Error: Collection of ZCB logs failed. 
On Windows Vista, Windows 7 and 2008 Server, the Tools->Collect Logs can have errors if they are not 
run as Administrator user. To resolve this issue, right click on ZCB Support in Start->Programs menu and 
click on Run as Administrator. 

Error: Failed to Validate encryption certificate : <CertificateName> 
The encryption certificate name entered in ZCB UI Backup What for the backup set is invalid. Encryption 
certificate name must have been imported into the amandabackup user profile on the ZCB machine. 

Error: Decryption initialization failed while finding certificate : 
<CertificateName> 
The encryption certificate CertificateName used at the backup time must be available for restoration of 
encrypted backup images. It should be have been imported into the amandabackup user profile on the 
ZCB machine where restoration is being done. 

 

Error: Decryption initialization failed while importing session key. 
You might encounter this error, if you are restoring on a machine different from where the archive, or if 
the amandabackup user profile on the same machine was deleted manually or as part of uninstallation 
or the password for amandabackup user has changed. This is a result of not importing the encryption 
key container used during encryption. To resolve this, you will have to import the necessary key 
container from the machine where the archive was backup encrypted. See Getting Started (Help → 
Getting Started in the UI or Zmanda Network documentation) guide for information on how to import 
key containers. Note: If you are using encrypted backups, Please make sure the amandabackup user 
password remains the same for the backup and recovery process. 

 

Error: Failed to initialize COM for VSS OR  

Error: Failed to initialize VSS OR 

Error: Failed to collect writers information OR 

Error: Backup failed for more than 100 or 50% of the selected files. Check 
Volume Shadow Copy services OR 

Error: Writers status is not stable. Try after restarting Volume Shadow Copy 
service. Please run 'vssadmin list writers' to identify the problem vss writer. 
These error messages related to VSS (Volume Shadow Services) can be seen during backup or validation 
of backup set. The application event logs should be checked for errors. Based on error codes in the logs, 
corrective action should be performed. The Windows command “vssadmin list writers” can also be 
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useful to identify VSS writer problems. Restarting Volume Shadow Copy service fixes most VSS writer 
problems.  

The list of files that were not backed up in the last backup run can be found in BackupErrors.txt file in 
the ZCB Debug folder. A similar debug file is available for restore failures (RestoreErrors.txt in the ZCB 
Debug folder). Some errors found in this log file can be ignored. 

Error: Amazon S3 Certificate not found in the installation directory. Backups 
and Restores to the S3 cloud will not work. Please purchase S3 subscription or 
download S3 certificate from Zmanda network. 
Backing up to Amazon S3 and restoring from S3 requires an authentication certificate. This certificate is 
available as part of product subscription. Please use Tools->Purchase Subscription to purchase a 
subscription. If you are already a product subscriber, download the certificate from Zmanda network 
account and import the certificate into ZCB using Tools->Import Cloud Certificate. 

Error: Time-mismatch: Difference between Amazon S3 time and System time 
is too large. Please check your server date and time. 
Amazon cloud requires the system time of ZCB machine to be correct. Please synchronize the system 
time with valid time (NTP) server. 

 

Error: Invalid User token: The provided token is malformed or otherwise 
invalid. OR 

Error: Failed to connect to Amazon S3 due to invalid certificate OR 

Error: Invalid access key: The AWS Access Key Id you provided does not exist 
in our records. OR 

Error: Invalid Secret key: The request signature we calculated does not match 
the signature you provided. Check your key and signing method. 
 

The Amazon S3 certificate installed on the machine is not valid. Please download S3 certificate from 
Zmanda Network and import the certificate to ZCB. Check Amazon S3 subscription using Tools->S3 
Billing. 

 

Error: Storage cloud communication errors 
Communication with Cloud failed. Detailed error message is available in the log files. Use Tools->Check 
Amazon S3 Connection to verify connectivity to the cloud. If the connection is good, try resuming the 
upload operation will work. Failed uploads can be resumed from Reports page. Select the backup job 
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report and right click to perform retry upload operation. The failed upload resumes from the failed block 
(not from the beginning of the backup image).  

Check to see if you have configured HTTP proxy information on the Tools->Advanced Options correctly. 

 

Error: mysqldump: Got error: 2003: Can't connect to MySQL server on <IP 
address/name> (10061) when trying to connect 
Backup of MySQL database fails with this error message. Check to see if the MySQL server is running on 
the server with the IP address or name mentioned in the message. Backup of MySQL database requires 
MySQL server to be running. 

 

Error: Cannot run program "mysql": Create process error=2, The system 
cannot find the file specified. 
Please check MySQL Utilities Path is specified correctly in the Backup What page in the UI. The value 
should be path where MySQL client utilities are installed. 

 

Error: Upload failed due to backup run failure 
This message appears in Upload pane of Monitor page. Failed backups cannot be uploaded. Look at 
Backup pane in the Monitor page for backup errors. 

Error: You have launched 'Collect Logs' using <user name> user. The tool will 
fail to collect logs correctly for any user other than Administrator. Please run 
'Start Menu > Programs > Zmanda > Zmanda Cloud Backup > ZCB Support' 
using 'Run as Administrator' option 
ZCB log collection for Zmanda support must be performed as Administrator user.  

 

Error: Validation of backup set <backup set name> failed. Check if ZCB service 
ports (see Tools > Advanced Options) are used by another software using 
netstat command OR 

Error: ZWC service could not be started. Please check if ZCB ports (Tools > 
Advanced Options) are in use 
ZCB uses two TCP ports for its operations. Default port numbers are 10080 and 10081. If these ports are 
used by some other software installed on the ZCB machine, the above error message is displayed. Users 
can change ZCB ports from the UI using Tools > Advanced Options. Use netstat command from the 
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Windows command shell to determine the list of ports used by software applications running on the 
machine. 

 

Error: Could not open file 
ZCB does not have the necessary read/write permission on the Backup Folder. Ensure that ZCB has write 
permissions on the Backup Folder.  

Error: Nothing to do 
This message indicates you are trying to restore an unsuccessful backup.  

 

Error: Backup root directory not specified, Assigning default value 
This error indicates either of the following:  

• An invalid/non-existent Backup Folder has been specified in the backup set.  

• ZCB lacks necessary permissions on the directory.  

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
page. Make sure that Backup Folders are present and accessible to ZCB.  

 

Error: Backup info fields not specified 
This error indicates either of the following:  

• An invalid/non-existent Backup Folder has been specified in the backup set.  

• ZCB lacks necessary permissions on the directory.  

Note: The Backup Folder refers to the directory path specified for the backup set in the Backup Where 
page. Make sure that Backup Folders are present and accessible to ZCB.  

 

Error: Restoring from a backup which was not successful 
This message indicates you are trying to restore an unsuccessful backup.  

 

Error: Backup status is not available in the index file 
This message indicates you are trying to restore an unsuccessful backup.  
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Error: Restoring from this may not be successful 
This message indicates you are trying to restore an unsuccessful backup.  

Error: Unable to access following File(s)/Folder(s) that are part of the 
<backup set name> backup configuration: 
This warning message appears if some files that were part of backup set are no longer in the system. The 
message identifies the list of files that are missing. Users are expect to save the backup set so that the 
missing files are removed from the backup set. 

Error: Please perform a Full Backup before a Differential/Incremental backup 
At least one full backup must be performed for a backup set before incremental or differential backup 
can be performed. Incremental/Differential backup contains changes since the full backup of the backup 
set. 

Error: Cannot run an incremental backup after a differential backup OR 

Error: Cannot run a differential backup after an incremental backup OR 

Error: Cannot add a differential backup schedule as an incremental backup 
schedule is already present OR 

Error: Cannot add an incremental backup schedule as a differential backup 
schedule is already present 
Users cannot switch from incremental to differential backup (level 1) and vice versa for a backup set. A 
backup set can have full and differential backup or full and incremental backups. 

Error: Validation of backup set not done. Another operation already in 
progress 
Validation of a backup set cannot be performed when backup or restore operation in the backup set is in 
progress. The backup set configuration is saved. The backup set should be validated later using 
File>Validate Backup Set. 

 

Error: Restore could not proceed as no VSS writer information is available 
During restoration of Exchange or SQL server, the corresponding VSS writer is not running. For MS 
Exchange, please check Microsoft Exchange Information Store service and restart it. Restart the SQL 
VSS Writer service in case of SQL server. 

 



465 S. Mathilda Ave., Suite 300 • Sunnyvale, CA 94086 • 1-888-496-2632 • www.zmanda.com 
 

Error: Restore failed as restoring Exchange 2003 data to recovery storage 
group is not supported 
Exchange 2003 backups cannot be restored to recovery storage group. This feature is not supported. 
Exchange 2007 can be restored to recovery storage group and Exchange 2010 can be restored to 
recovery database. 

Error: Writers status is not stable. Try after restarting Volume Shadow Copy 
service. Please run vssadmin list writers 
The VSS writers are not in Stable state. This can happen if all service packs for Microsoft Windows has 
not been installed. It can also happen if you add a SQL server database to the machine and attempt a 
differential backup. When you add SQL serfMSver database, you should perform a full backup. Restart 
the failed VSS writers and Volume Shadow Copy service. 

 

Error: Restore could not proceed as VSS initialization failed 
• During restore process, Volume Shadow Services is used. The status of VSS writers should be 

stable. Please check the output of command vssadmin list writers and restart failed VSS writers 
before attempting restoration again. 

• This error message can occur during Exchange restoration. Check for errors in the Application 
Event Logs from MSExchangeIS. For example: If mailbox stores in a storage group are not 
dismounted during a restore, the application event logs has message Restore not permitted 
because storage group <storage group name> is online. 

• This error can also be seen if the user has not selected “This database can be overwritten by 
restore” option in the Mailbox Store properties on the Exchange server. The Event log also 
shows error. An example event log error message “Exchange VSS Writer failed restoring a 
backup because the database 'MailboxDatabase.edb' in 'C:\Program Files\Microsoft\Exchange 
Server\Mailbox\FirstStorage Group' of storage group 'First Storage Group' is targeted for 
restore, but it has not been marked for overwrite” 

Error: Failed to connect to SQLServer. Please ensure that you have added 
windows/domain user "amandabackup" with sysadmin privileges to 
SQLServer and  have enabled TCP/IP networking on that server. 

 OR 

Error: MSSQL Log backup failed 
SQL server backup requires amandabackup SQL user with correct credentials for performing backup and 
recovery. This message implies the user does not have appropriate credentials. Please see requirements 
listed in the MS SQL server section. Fix the credentials and validate the backup set before running 
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backups. Please note SQL server validation will not check to see if amandabackup SQL user has sysadmin 
server role and must be in SQL security group. 

Error: MSSQL Differential backup failed 
Differential backup of MS SQL server failed. This can happen if SQL VSS writer has failed. Check vssadmin 
list writers command output. 

 

Error: Query for database recovery model failed. Check logs for more details. 
During backup, ZCB queries the MS SQL databases for their recovery model. This error message occurs 
when the query fails. Please report this error to Zmanda Support Team with the logs (Tools->Collect 
Logs) for analysis. 

 

Error: Specified backup component name is not valid. 
During backup, ZCB queries the SQL Writer for the databases saved in the selection list. This error 
message occurs when one or more databases saved in the selection list goes offline. If the database has 
been marked offline on purpose by the SQL Administrator, then click on the Refresh button on the 
Backup page for ZCB to re-scan for the online databases and save the backup set.  

 

Error: The requested application does not seem to be installed on the 
machine. 
This error message occurs during validation of a backup set that contains SQL server or Exchange server. 
It means the SQL server or Exchange is not installed on the ZCB machine or could not be contacted. 

 

Error: Recovery Storage Group/Database not found 
This error occurs during restoration to recovery storage group in Exchange 2007. This error can occur for 
following reasons: 

1. If the recovery storage group name specified in Restore Where does not match Exchange 
configuration, this message is displayed. Please provide the correct storage group name. 

2. The amandabackup user has not been added to the Exchange View-Only Administrators group. 
Add amandabackup user to Exchange View-Only Administrators group and restart the 
ZWCService to resolve the error. 
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Error: Restoring to Recovery Storage Group/Database is not supported for 
backups taken by previous client version 
You cannot restore Exchange backups taken by ZCB version earlier than 3.0 to recovery storage 
groups/recovery databases. 

Error: Failed to create backup directory 

OR 

Error: Failed to create restore directory 

OR  

Error: Failed to create download directory 
 

This error signifies permissions issue.  If you are getting this error while doing manual backups or 
restores, please ensure that the user which has launched the ZCB user interface has the read/write 
permissions on the backup media, restore directory and download directory. 

If you are getting this error while running scheduled backups of a mapped drive, this error comes up as 
ZCB scheduled backups run as SYSTEM user which will not have necessary privileges to access mapped 
drive. To resolve this, specify the user credentials of a user with read/write permissions on the network 
mapped drive ( e.g. “amandabackup” user) in the Backup Set Preferences tab under the Backup When 
section. This will cause the schedules to run with the privileges of this specified user and hence will fix 
this issue. 

Error: Application <pre|post> <restore|backup> script failed. Check 
ZWCService logs for more details 
The pre or post backup or restore script that is configured for the backup set failed. The ZWCService log 
file in the Debug sub-folder of the ZCB installation directory has more details about the failure. Any non-
zero (or special status of 65531) exit status from the script is considered as a failure.  

 

Error: Application skipped the backup. Check ZWCService log file for more 
information. 
The pre backup script returned exit status of 65331. This special exit code allows pre-backup script to 
skip a backup run. The same exit status from pre restore script cause restore to be skipped. The backup 
and restore operation is treated as successful.  
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