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Terminology 
What is Zmanda Cloud Backup? 
Zmanda Cloud Backup is the complete backup solution for Windows servers. It backs up file systems and 
live applications such as Microsoft Exchange and SQL Server to highly dependable storage cloud – 
Amazon S3. 

What is a backup set? 
All activities in ZCB are applied to backup sets. A backup set defines the parameters (the what, where, 
and when) for backing up a group of directories or an application such as Exchange. Each backup set can 
only be of a single type. For example, you cannot back up an Exchange server and Windows System state 
in the same backup set.  

What is amandabackup user? 
All ZCB services run as amandabackup user. During installation, the amandabackup user is added to 
“Backup Operators”, “Administrators” and “Users” user groups. This user is essential for ZCB 
functionality. The behavior for the creation of the amandabackup user is as follows. 

Windows domain NOT configured on ZCB machine 

• The amandabackup user is created if it doesn’t pre-exist on the machine 
• The supplied password needs to be correct if amandabackup user pre-exists on the machine 

Windows domain configured on ZCB machine 

If amandabackup user pre-exists on the domain, it is reused. The supplied password needs to be correct. 

If amandabackup user doesn’t pre-exist on the domain, then 

• The amandabackup user is created locally if ZCB machine is NOT the domain controller 
• The amandabackup user is added to the domain if ZCB machine is the domain controller 

The amandabackup local user may be deleted at the time of uninstallation depending on whether or not 
you choose to preserve data during uninstallation. 

What do you mean by “full”, “differential” and “incremental” backup levels? 
ZCB supports full, differential and incremental backups.  

Full backup: This level of backup makes ZCB to back up all the data associated with the backup set. This 
is also called as backup level 0. 

Differential backup: This level of backup makes ZCB to back up only the data which changed since the 
last successful full backup. This is also called as backup level 1. 
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Incremental backup: This level of backup makes ZCB to back up only the data which changed since the 
last successful full or last incremental backup. This is also called as backup level 2 or more. 

For more information, please see When should I use differential or incremental backup levels? 

ZCB Features 
What are the new features in ZCB 4.0? 

Functionality 
• Selective backup of MS-SQL and MS Exchange Server 
• Differential backup of MS SharePoint 
• A new “Backup to cloud” operation, to backup directly to cloud without the need of storing 

data on the local disk 
• Pause/Resume of a “Backup to cloud” operation 
• Support for custom Pre-Restore and Post-Restore actions 
• Improved retention policies for better data protection 
• Support for Amazon S3 – Tokyo Region. 

Usability 
• A new GUI with many new usability improvements 
• One screen, simultaneous monitoring of all backup sets 
• Flexible scheduling options 
• User friendly email notification functionality 
• Parallel backup, restore, validate and estimate operations 

Performance 
• Significantly faster downloads and uploads (up to 3 times faster) 

Bug Fixes 
• Deleted files shouldn’t be restored if desired restore point didn’t have those files 

 

What are the different ways in which ZCB can perform backups?  
ZCB supports following ways to perform backups: 

“Backup to Cloud” 
This is a new operation in ZCB 4.0. This means that ZCB will start uploading data as it begins getting 
backed up. No local copies of backup data will be available. Since the data is only available on the cloud, 
the retention policy configured under the “Cloud Storage” heading of “Backup Where” section will be 
applicable. 

If you have upgraded from ZCB 3.0.2 release 



465 S. Mathilda Ave., Suite 300 • Sunnyvale, CA 94086 • 1-888-496-2632 • www.zmanda.com 

Please note that ZCB versions before release 4.0 had an operation called “Backup to S3”. This has been 
renamed to “Backup to both Disk and Cloud” in release 4.0. Hence, your existing backup schedules with 
operations “Backup to S3” will continue to run as “Backup to both Disk and Cloud” operations in ZCB 4.0.  

 “Backup to Disk” 
This means that ZCB will backup data to local disk. Please note that under this operation, ZCB will not 
upload backed up data automatically. It is expected that user will launch an upload operation separately 
at a later time, according to user’s preference.  If the user doesn’t upload backup data, only the 
retention policy configured under the “Local Storage” heading of “Backup Where” section will be 
applicable. 

“Backup to both Disk and Cloud” 
This means that ZCB will make two copies of backup data – one each on disk and the cloud. To make 
backup operations fast, this operation is a two stage process. First, the data is backed up to local disk. 
Once this is complete, a copy of data is uploaded to the cloud. 

Since the data is available both on disk and the cloud, the retention policies under both “Local Storage” 
and “Cloud Storage” headings on “Backup Where” section will be applicable. 

Can I do backup and upload at the same time? 
Yes. From ZCB 4.0 onwards, you can choose the “Backup to Cloud” operation which starts uploading 
data as it is getting backed up. However, please note that no local copies of data will be available in this 
case.  

Can I install ZCB on multiple machines and use my Zmanda license on them? 
Yes. In this case, all ZCB instances will be using same s3 storage. 

What file extensions you support?  
ZCB supports backup and restore of all types of files. 

Is ZCB HIPAA compliant? 
Zmanda Cloud Backup supports various requirements to comply with HIPAA regulations when it is 
properly configured and is implemented as part of a fully HIPAA compliant solution. When applied to 
cloud backup, HIPAA regulations largely apply in two areas - data privacy and data security. 
 
Data privacy: The backup data is transmitted to Amazon datacenters over 128 bit SSL channel. The 
backup data can be encrypted on the ZCB machine, before it leaves the customer site. Encryption is 
performed using standard RSA RC4 algorithm and the encryption keys are owned and managed 
completely by users and hence once data is encrypted, it can't be decrypted by either Zmanda or 
Amazon Web Services. 
 
Data security: ZCB provides support for backup to multiple Amazon S3 geographic locations to mitigate 
the risk of failure. ZCB backup data is never transmitted to Zmanda servers and is stored only on 
datacenters managed by Amazon Web Services. Since customer authentication details are known to 
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Zmanda, the data stored on Amazon servers can be accessed by Zmanda technical support engineers to 
resolve the customer issues. This access, however, is only upon customer request and is stringently 
monitored by Zmanda management. The backups are stored in Amazon S3 in special buckets that can be 
accessed only by ZCB product. 
 
Once ZCB transfers data to Amazon data centers, Amazon safeguards and manages the data as per their 
published security policy document. Please refer to the Amazon Web Services: Overview of Security 
Processes document for more details on data privacy and data security measures. 
 
For more information about HIPAA compliance, please see 
http://www.hhs.gov/ocr/privacy/hipaa...eguidance.html  

Using ZCB 
What platforms/applications are supported? 
Platforms: Windows 2003 server, Windows 2008 server R2, Windows 7, Windows Vista and Windows 
XP. 

Applications: ZCB supports NTFS file system, System state (active directory, registry, certificate server), 
MySQL 5.x, SQL server 2000, 2005 and 2008, Microsoft Exchange 2003, 2007 and 2010, Share Point 2010 
and 2007 and Oracle 11g running on any of the listed platforms.  

Can I run ZCB as a user not belonging to Administrator group? 
No. Only a Windows user belonging to Administrator's group can install and perform ZCB operations 
using the UI.  

On Windows XP and Windows 2003 server, if a user that does not belong to Administrator's group 
launches ZCB UI, the error message Write permission denied is displayed. User can right click on ZCB UI 
short cut and select Run As option. Specify the Administrator user password to launch ZCB UI. 

On Windows Vista, Windows 7 and Windows 2008 server, if a user that does not belong to 
Administrator's group launches the UI using ZCB short-cut, the User Access Control dialog will appear. 
Enter Administrator user account name and password. ZCB UI will be launched. 

How do I enable VSS (Volume Shadow Services)? 
The Volume Shadow Copy Service must be enabled for ZCB backups. Although the Volume Shadow 
Service is enabled by default, it may have been turned off after Windows installation. To ensure that it is 
running:  

Right-click the My Computer icon and choose Manage from the popup menu.  

Expand the Services and Applications tree and locate the Volume Shadow Copy Service.  

http://www.hhs.gov/ocr/privacy/hipaa/administrative/securityrule/securityruleguidance.html
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If it is not started, do so.  

If necessary, change the General Properties to make the Startup Type Automatic rather than Manual.  

How can I manage my backup sets? 
Backup sets are listed along the left edge of the ZCB display. You can delete, deactivate or validate a 
backup set by right-clicking on it and choosing from the pop-up menu.  

Backup set names are limited to 32 alphanumeric characters. A backup set must be activated (which is 
the default state) for the backups it defines to actually be performed as scheduled. 

What happens when I “deactivate” or “validate” a backup set? 
Deactivating a backup set: Doing this on a backup set would mean that no operations such as backup 
or restore can be performed on that backup set. All scheduled tasks for this backup set are disabled too. 

Validating a backup set: This is a simple way to check whether the essential configuration for the 
backup set is correct or not. If there are errors during validate, it indicates that the ZCB won’t be able to 
use the configuration provided by the user to perform backup/restore operations correctly. 

When should I use differential or incremental backup levels?  
Choosing differential and incremental backup reduces the amount of data to be backed up and 
uploaded to Amazon S3. Incremental backups can be smaller in size compared to differential backups. 
But, differential backups allow for faster restoration compared to incremental backups. 

It is not possible to do mix incremental and differential backup for a backup set. If you configure a 
backup set to do differential backups, you cannot use incremental backups for the backup set. 

What do I configure in “Local Storage” section on the Backup page? 
If you want to keep backup data just on the cloud, you don’t need to configure the Local Storage 
section. This will be the case when you use Backup to cloud operation in ZCB 4.0. 

However, if you wish to put backup data to a local disk (Backup to Disk or Backup to both Disk and 
Cloud operations) then you would need to configure the fields in the Local Storage section. 

Can I backup data from a mapped network drive? 
Yes. ZCB supports backing up mapped drives provided the shares are accessible by amandabackup user. 
ZCB supports both Windows and SMB shares mapped as drives. Backup of NTFS encrypted files on 
mapped network drive will fail with Access Denied error. 

Requirements: 

The amandabackup user must be a valid user on the machine whose network share is being accessed by 
ZCB machine. The password must be the same. 
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If the ZCB machine and the machine where the Network share is present, are part of a Windows domain, 
then make sure that the ZWCService is started with the domain amandabackup account i.e. 
domainname\amandabackup. 

On the ZCB machine, map the network share so that the user who launches the ZCB user interface is 
able to view the mapped drive in the Windows explorer. 

Can I use a mapped network drive as the Local Storage on the backup page? 
Yes. You can use a mapped network drive to store backup images. To configure mapped network drive 
as the backup folder, perform the following steps: 

Ensure that amandabackup user has read and write access to the network share. 

Map the network share as a mapped drive using the backup user (Administrator user). 

In ZCB Backup page, under the Local Storage section, use the browse button next to Location box to 
select the mapped drive. 

You will have to modify the ZCB scheduler entries in the Windows Task Scheduler to run as 
amandabackup local or domain user. 

How do I backup NAS shares? 
Map the NAS share as a network drive. See the answer to the question Can I backup data from a 
mapped network drive? 

Can I backup Linux clients? 
Yes using Samba. ZCB can backup data from mapped Samba shares from the Linux machine without 
using VSS (locked and open files are not backed up). There is no Linux ZCB client. Amanda Enterprise 
edition provides this functionality. Please contact Zmanda Sales (Email zsales@zmanda.com) for more 
information. 

Does ZCB support FAT32 filesystem or Netware shares? 
ZCB can backup only NTFS filesystem. FAT32 filesystem can be used for Backup Folder if backup 
encryption is not required.  

How do I configure ZCB to back up SQL Server 2000, MS Exchange and Oracle 
servers? 
The steps are: 

• Install and run Zmanda Cloud Backup on the server you intend to back up.  
• Go to Backup page. 
• In the “Backup What” section, choose the desired Backup Type.  
• Zmanda Cloud Backup will discover all the instances of the chosen server and automatically 

add them to the backup set.  

http://www.zmanda.com/amanda-enterprise-edition.html
http://www.zmanda.com/amanda-enterprise-edition.html
mailto:zsales@zmanda.com
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How long are the backups retained in the local backup folder and on S3 
storage? 
Local and S3 backups are retained as specified by the retention policies entered in the Backup Where 
section on the Backup page. You can choose to retain backups for months, days, years or forever, based 
on space availability and recovery requirements. 

Do I need to restore a full backup and then restore the 
incremental/differential backup(s) to restore to a point in time? 
No. Zmanda Cloud Backup lets you select any point in time (based on when the last backup was 
performed, and then automatically determines which backups must be restored.  

How do I restore to a different directory? 
The Restore Page includes an option to restore to a different directory.  

Can I control the bandwidth being used by ZCB for upload/download? 
Yes. By default, ZCB always attempts to use the maximum bandwidth you have available. 

However, if you wish to specify the limits for bandwidth to be used by ZCB, you can specify these two 
values: 

Max Upload Rate: This value, in kilobits per second, refers to the maximum bandwidth ZCB will use for 
uploading backup data to the cloud. 

Max Download Rate: This value, in kilobits per second, refers to the maximum bandwidth ZCB will use 
for download backup data from the cloud. 

ZCB allows you to set these two values both at a global level and at a backup set level. For configuring 
these values globally, across all the backup sets, please go to Preferences > Bandwidth. For configuring 
these limits at a backup set level, so that they override the global values, please go to Cloud Storage 
sub-section on the Backup Where section. 

 

My backups take a long time to complete. What can I do to speed it up? 
The upload speed depends on bandwidth availability. However, if you believe that ZCB is not using the 
available bandwidth completely, please do the following: 

• Make sure that bandwidth throttling limits are not configured. Please see the FAQ Can I control 
the bandwidth being used by ZCB for upload/download? 

• Tweak the values in Preferences > Maximum thread Counts. If you increase the number of 
threads, the upload/download generally speeds up due to concurrent data transfers. However, 
beyond a point the performance might not improve further, or it might even fall due to other 
overheads. 
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• Adjust the schedules so that uploads occur when maximum bandwidth is available. You can 
upload multiple backup sets at the same time. 

I cannot use the machine when backups are running. What can I do? 

ZCB uses the Windows Volume Shadow Services (VSS) to perform backups. VSS minimizes impact on the 
application. But because system resources such as CPU cycles and memory are shared, the impact 
cannot be entirely eliminated. Compression in particular can consume significant system resources.  

Why can’t I change the cloud location for a backup set?  
The cloud storage locations are all totally different from each other. If backup data is spread across 
multiple cloud locations, it will be difficult for ZCB to perform restores. Hence, once you choose a cloud 
storage location and save a backup set, you can’t change it. 

If you wish to use a different cloud storage location, please create a different backup set. 

How can I delete old backup data from cloud? 
You can configure ZCB to automatically delete old backup data by configuring suitable retention policies. 
Please refer to the How long are the backups retained in the local backup folder and on S3 storage?  

However, if you wish to manually delete data which has not expired as per the retention policy, then 
you can do so. Please go to File > Purge All Backup Runs Before and choose a calendar date. This will 
delete all the backup data from the cloud storage before this calendar date. Please note that the backup 
data on local disk will not be deleted. 

 

Why do I see so many User Access Control pop-up messages while using ZCB? 
When ZCB is run using a non-Administrator user, one will see UAC messages on Win Vista, Win 7 & Win 
2008. ZCB requires elevated privileges to create, delete & query schedules. So, when ZCB tries to create, 
delete or query the Windows scheduler, it throws a UAC pop-up so as to make sure that the actions are 
run under elevated privileges. 

Advanced Operations 
 

Can I copy the backup folder to another machine? 
Not directly. To move a backup folder to a different machine, first upload from the source machine to 
S3, then restore the backup catalog to the target machine as described in How do I restore to different 
machine?. 
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Can I move existing local backups to a different disk location? 
Yes. If you have been using ZCB to keep backup data on your local disk and now wish to move this old 
data to a new location on your machine (a different drive for instance), you can do so. For this, you will 
have to use the movebackup option of zwcontroller.exe program which ships with ZCB. 

Please refer to the movebackup operation documentation in the Administration section of the ZCB user 
guide. 

How do I restore to different machine? 
The backup must reside in S3 storage. Backups stored in the local backup folder cannot be restored to 
another machine using this process. If you need to restore in a scenario with you have no backups on 
the cloud storage,, please open a support case. 

Install and run Zmanda Cloud Backup on the restore target machine.  

If the backup is encrypted, make sure the required encryption certificates from the backup machine(s) 
are available on the restore target machine. If the backup archives have been created using ZCB prior to 
3.0 release, the Zmanda key container is also required on the restore target machine. 

From the Tools menu, choose Restore Catalog to restore the backup. You must supply a host (host 
name of the original server) and backup set name to identify the backup used for the restore. If backup 
set name is not specified, all backup sets found in the original server, will be recovered on the new 
server.  

All the recovered backup sets will be named “<backup set name> (<original hostname>)” 

Use ZCB to restore the files as if they were on the original machine. You can also look at the reporting 
information for the recovered backup sets. Please refer to the Restore section in the ZCB user guide for 
more information. 

Does ZCB log events to Windows Event Viewer? 
Yes. All Backup, Upload, Download and Restore successful and failure events are logged.  In addition, if 
email notifications have been configured on ZCB, any failure while sending emails will also be logged in 
the Windows Event Viewer. Following output shows an example of Backup failure.  

Event Type:     Error 
Event Source:   ZCB 
Event Category: Backup-Restore  
Event ID:       501 
Date:           7/7/2009 
Time:           5:40:33 PM 
User:           N/A 
Computer:       EXCH-SERVER-1 
Description: 
 BackupSet3 - Backup failed with errors. 
 Error Details : File system not supported. 
 
 Please check log files for details. 
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Why is the Backup Size on the Backup Page different from the Total Upload 
Size reported on the the ZCB Monitor Page? 
The Backup Size on the Backup page shows the size of Backup archive. The Total Upload Size on the 
Monitor page  includes the backup meta data and catalog for the archive in addition to the backup 
archive. So the Total Upload Size will be greater or equal to the Backup Size value. The backup archive 
metadata and catalog is required to recover the catalog in case of disaster recovery of ZCB machine. 

Amazon S3 Cloud 
How can I verify the validity of the S3 Certificate and Connection? 
Choose Cloud->Check Cloud Connection. This causes ZCB to connect to S3 and validate the required S3 
subscription and keys. You can use this test to validate your installation, or to troubleshoot failed 
uploads/downloads. 

I'm getting Amazon subscription failure errors trying to access the Zmanda 
Network Downloads page. Why? 
To access Zmanda Network downloads page, please click here.  

Do not access ZCB product using http://www.amazon.com/dp-applications or https://aws-
portal.amazon.com/gp/aws/user/activation/index.html or 
http://network.zmanda.com/questionnaire.php. Please note that this process ends up regenerating 
your Amazon S3 certificate which renders your old/current S3 certificate useless and ZCB will fail to 
upload data to S3 and restore data from S3. You will have to download new S3 certificate and import it 
in ZCB using ZCB user interface. 

How secure is my data with ZCB and Amazon S3? 
There are several levels of security provided by ZCB and Amazon S3 that ensure privacy and security of 
your data:  

• ZCB provides an option to encrypt your backup data by using Digital Certificates from Trusted 
Certificate Authorities or using self-signed certificates you can generate yourself. 

• In addition to encrypting the backup data, ZCB provides an option to transfer your data from 
your computer to Amazon S3 via secure 128-bit SSL.  

• Amazon S3 provides access controls that only permit authenticated access by ZCB with your own 
unique security certificate. You, and only you, maintain full control over who has access to your 
backup data. See this white paper from Amazon (requires Adobe Acrobat reader) for details.  

How to purchase Amazon S3 subscriptions? 
If you bought ZCB from website and downloaded both ZCB installer and s3 certificate, then you don’t 
need to do anything. You can simply import the certificate to ZCB using Cloud > Import Cloud Certificate 
menu.  

http://network.zmanda.com/index.php?redirect=download.php
http://www.amazon.com/dp-applications
https://aws-portal.amazon.com/gp/aws/user/activation/index.html
https://aws-portal.amazon.com/gp/aws/user/activation/index.html
http://network.zmanda.com/questionnaire.php
http://s3.amazonaws.com/aws_blog/AWS_Security_Whitepaper_2008_09.pdf
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However, if you have installed ZCB but don’t have s3 certificate which is required to use ZCB with 
Amazon S3 cloud, then you purchase a subscription. Please click on Cloud > Purchase Cloud Subscription 
to buy Amazon S3 subscriptions for Zmanda Cloud Backup. The purchase process requires Zmanda 
Network login information. Please join Zmanda Network for free at http://network.zmanda.com/  

After your purchase, Amazon S3 certificate will be available for download from Zmanda Network. Please 
download the certificate to the ZCB Windows server and import the certificate into ZCB configuration. 

How much are we spending? How much have we spent in the past? 
Please click on Cloud > Cloud Billing to view monthly billing activity and see what is being spent so far 
this month. You will need your Amazon account information to access the bill.  

How do I use a different Amazon S3 account? 
An additional S3 account requires an additional subscription, available from the Zmanda Network.  

Who sends the monthly bill? 
Monthly bill for ZCB license, storage and transfer cost will be provided by Amazon. It will appear in 
financial statements (credit card statements) under heading AMZN PMTS(Services and Merchandise). 

Zmanda does not bill the customer directly. The bill will have specific entries for Zmanda Cloud Backup 
in addition to entries for other Amazon Web Services if you are using them.  

Support 
I have a question which is not covered here. How do I get an answer? 
We invite you to Zmanda forums - http://forums.zmanda.com. Please search the ZCB forums for 
questions already asked by our users and resolved by the community.  

Please also see the FAQ I am facing a specific issue. How do I get support? if you have specific technical 
queries. 

I am facing a specific issue. How do I get support? 
You can contact our support by clicking on Help > Contact Support. This will open your browser and 
direct it to the Zmanda Support Forums. After logging in using your Zmanda Network account, you can 
open a support case. 

 

 

http://network.zmanda.com/
http://www.zmanda.com/pricing.html
http://forums.zmanda.com/
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